Forums » Fixing WordPress » Memory allocation / Order in which things load in edit

  • I have a relatively basic site using mostly common plugins and an experienced theme (Weaver Xtreme). My hoster is relatively vanilla, but I have had a recurring problem over the last four to five years that I’ve never been able to fix. I’ve seen people with similar issues, but they show up differently for them, and their fixes don’t work on my site.

    Here’s the basic issue. I go in to edit an existing post, maybe 1500 words. No graphics. One Featured Image. One category. No tags. 1 reusable block. Nothing overly “memory intensive”, if you get my direction.

    Yet the main text loads, the basic permalinks and things load in the sidebar, but my categories, tags, and featured images tag a VERY long time to load, if at all. I’ve done the obvious, played with various plugin removals, add them back in one by one, etc. But it’s not consistent. I’ve had it work with each and every one in the mix, individually and in bundles just fine. But when I get too many, it bogs down.

    I used to run about 40-45 plugins two years ago, and I thought sure, that was a lot. So I cut and cut and cut, and got it down to about 25 I really wanted. Site loads okay on the front end, but in the edit window? It could take 30s or so for the FI/Cats/Tags to load. Reusable blocks are also often unavailable for some time after I open the window. I used to be able to open multiple windows even and edit several pages at the same time. As WP versions increased, my ability to do that seems to have dropped. I don’t know if that is WP itself, but I can’t have more than about two open right now, and even then, it’s doubtful.

    Is there a way to see what order things are loaded in the edit window? I feel like somehow I’m running out of memory to load those other pieces, and because it takes so long, it times out. Sometimes the FI doesn’t EVER load. I know there is one, as I saw it in preview, but in edit? The section doesn’t even appear.

    Reusable blocks are a big one as well — even if I get the others to load, reusable often are not available at all. Not by name, not by menu. It’s like they don’t exist.

    Back when I was at 45 plugins, I said, Okay, I can cut back. I had more problems at 30-35. Now, I’m at 25, and if I go for about 15 plugins, I can load everything in five seconds. 16-18 or so, it drops to 15 seconds. Above 20 plugins, it drops to 30s+, and above about 23, it never loads at all.

    It sure SEEMS like a memory configuration problem. But I’m not sure where…

    Anyone have suggestions?

    Paul Sadler
    thepolyblog.ca

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    This problem may be a plugin or theme conflict. Please attempt to deactivate all plugins and switch to the default Twenty Twenty-One theme. If the problem goes away, re-activate them one by one to identify the source of the problem.

    If you can install plugins, install Health Check. On the troubleshooting tab, you can click the button to deactivate all plugins and change the theme for you while you’re still logged in without affecting normal visitors to your site.

    Thread Starter PolyWogg

    (@polywogg)

    Thanks James, I’ve confirmed multiple times that it is neither.

    If I deactivate all plugins, and run default themes (2017-2021) or my current theme, no difference. The edit window loads just fine. So it has to be a plugin, right?

    Except I’ll try them one by one, no issues. So it has to be a combo, right? That plugin one is conflicting with plugin two or something. Except I’ll play with multiple combos, everything works in WHATEVER order up until I get to about #15. Then it starts bogging down no matter WHICH 15 I have loaded. I feel like I could randomly grab any 15 popular plugins and it would grind the site to a halt.

    Interestingly, today I loaded Litespeed Cache which is what my server host likes best. I loaded the edit page with 20 plugins activated. It went slow. Backed out, reloaded, it loaded faster. Great. But not everything. Closed out again, reloaded. This time EVERYTHING loaded in under five seconds. So I loaded up another 8 plugins, now running 28, which it wouldn’t accept earlier. No problem at all.

    Caching sped up the back end too, which some caches don’t seem to do, I know. I would prefer NOT to run the cache on the backend, but it seems to be the ONLY thing that lets me load. Physical resource limits are getting flagged on teh server (512MB) and IO processes are overloading (2MB/S). Prior to cache, of course.

    Now it’s working. But shouldn’t it work WITHOUT the cache? It’s not that heavy a site…

    Paul

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    It sounds like caching is at the root of the problem here.

    Does your hosting provider offer any sort of built-in caching?

    If so, see if you can disable that.

    Thread Starter PolyWogg

    (@polywogg)

    It DOES provide built-in caching, but I had turned that off some time ago, as it conflicted with one of my plugins at the time, don’t remember which now. I’d really rather run it, I’m not a photo-heavy site anyway, nor am I particularly worried about rankings. It’s a personal site, people come to it for specific reasons, none of which are search engine derived. So if it loads a little faster or a little slower on the front end, I can live with it (I made it a bit more mobile friendly, but that’s about it). I have a lot of text spread over thousands of posts, but the website structure is not load heavy. So I could get by with no cache, and since caching interacted oddly at times, I had just disabled it.

    Interestingly, with the new cache enabled, and the back end running cached, I can load everything again. So technically it is “fixed” in the sense of “working”, just not working as per the normal load.

    For what it’s worth for posterity, here are the plugins I’m running:

    WP: 6.1.1
    THEME: Weaver XTreme

    CORE PLUGINS (15) — Everything works with these running, even without cache:
    – Front-end:
    – Display Posts
    – Display Posts – Date View
    – Flexible Table Block
    – Weaver Xtreme Plus
    – Weaver Xtreme Theme Support
    – Back-end:
    – Advanced Editor Tools (previously TinyMCE Advanced)
    – Akismet Anti-Spam
    – LiteSpeed Cache
    – ManageWP – Worker
    – Media Library Assistant
    – OG — Better Share on Social Media
    – Really Simple SSL
    – Redirection
    – Wordfence Security
    – WP to Buffer Pro

    SECONDARY PLUGINS I LIKE HAVING (11): Once I get above about 5 of these, the edit post window grinds to a halt
    – Front-end:
    – AddToAny Share Buttons
    – Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others
    – Simple Lightbox
    – Stackable – Gutenberg Blocks (Premium)
    – Yet Another Related Posts Plugin (YARPP)
    – Back-end:
    – MailPoet
    – MailPoet Premium
    – WPForms Lite
    – WP Mail SMTP
    – Nested Pages
    – Yoast Duplicate Post`

    TERTIARY PLUGINS I CAN DROP (4): The backend is easily disabled although I would prefer to keep WPDiscuz (comment manager). With Cache running, I can run all 30.
    – Front-end:
    – wpDiscuz
    – Back-end:
    – Dashboard Wordcount
    – Server IP & Memory Usage Display
    – Simple Blog Stats

    Paul

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Hm, yeah, were it me in this situation, I’d:

    1. Drop any plugins you’re not using.
    2. Re-enable the hosting provider’s cache and remove any of your own caching plugins.

    Hosting-level caches are typically far superior to caching plugins, and whatever conflict you had before may be gone by now.

    Thread Starter PolyWogg

    (@polywogg)

    Thanks James. Super frustrating. I had it working well again and then suddenly, it’s bogging down even with 15 plugins running, and I don’t even have the security or cache ones running yet. Sigh.

    Thread Starter PolyWogg

    (@polywogg)

    Enabled Hosting cache, disabled other stuff. Checkd my settings, is there anything really wonky anywhere in this for PHP.INI:

    max_execution_time = 90
    max_input_time = 60
    max_input_vars = 1000
    memory_limit = 512M
    post_max_size = 500M
    session.gc_maxlifetime = 1440
    upload_max_filesize = 450M
    zlib.output_compression = Off

    On another site, I have max_execution_time at the default of 30; memory_limit set to only 128M; post max size at 1024M; and max_filesize for upload at only 2M.

    Is it possible the max execution time or the Upload size could be throwing things off?

    Paul

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Memory allocation / Order in which things load in edit’ is closed to new replies.