Support » Plugin: Duplicator - WordPress Migration Plugin » Memcached issue after migrating site

  • Resolved unregularjohn


    So after searching and searching I’ve come to the conclusion that the issue I’m having is likely due to migrating a WordPress site from a Linux server to my local windows machine as a test environment.

    Getting this error:
    Fatal error: Class ‘Memcache’ not found in C:\xampp\apps\wordpress\htdocs\wp-content\plugins\w3-total-cache\lib\W3\Cache\Memcached.php on line 38

    This is coming after I have installed the package I took from my live site. Using XAMPP and WordPress on a Windows 7 machine.

    Anything I can do to fix this problem or should I setup a copy of linux for setting up a local testing machine?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Cory Lamle


    On the second step of the installer there is an Advanced Section. Open it up and disable the W3C total cache plugin. This will keep WP from running that plugin which is currently setup to run the Memcached.php file.

    You may also poke around on the W3 Cache forums to see how to properly disable the plugin during a move…

    It is possible to install Memcache on a Windows machine. Often this can help you validate things won’t break when you move from the dev to he production server too.

    If you grabbed the “kitchen sink” version of XAMPP then the only thing you usually need to do is install the executable from the first link below, then enable Memcache in XAMPP by removing the “;” from the following line in your php.ini, & then stop/start Apache:

  • ;extension=php_memcache.dll
  • If that doesn’t work then you probably need to install the Memcache extension for PHP from here: Check Google for instructions on doing that for your specific version of Windows, but be aware that the “VC9” or “VC6” in the extension you install needs to match what your XAMPP version (current versions of XAMPP use VC9,

Plugin Author Cory Lamle


HI, I need some help here. I have tried to use Duplicator and I’m getting the following errors related to memcache.

Warning: include(/Users/cam/Sites/zmm2/wp-content/advanced-cache.php) [function.include]: failed to open stream: No such file or directory in /Users/cam/Sites/zmm2/wp-settings.php on line 58

Warning: include() [function.include]: Failed opening ‘/Users/cam/Sites/zmm2/wp-content/advanced-cache.php’ for inclusion (include_path=’.:/Applications/MAMP/bin/php5.3/lib/php’) in /Users/cam/Sites/zmm2/wp-settings.php on line 58

Fatal error: Class ‘Memcache’ not found in /Users/cam/Sites/zmm2/wp-content/object-cache.php on line 346

Any help would be great.


Plugin Author Cory Lamle


Hey Findcam,

Check out this link it may help…

Hey thanks for the quick response. I’m on a mac running mamp 1.9.4. so that link isn’t for me, but I did find one for Mac os X

Do you know if I have to set this up in order to use the duplicator? I run sites locally all the time and have never needed this. Is there a reason why this is popping up now with the duplicator install?

Plugin Author Cory Lamle


Hey Findcam,

Maybe you have a plugin or setting that is triggering that section of code to get called somewhere… It may not happen if you duplicated a base wordpress site… You may also check your wp-config.php to see if any cache variables are enabled…

I have disabled all the plugins by renaming the plugins folder and it is still the white screen of death. lol

It did happen with a really simple base site, that was just multi site and that was all.

“You may also check your wp-config.php to see if any cache variables are enabled…”

What would I be looking for exactly? Thanks so much, I would really like to be able to use this plug in for all the work that I do.

Plugin Author Cory Lamle


Hey findcam,

The plugin currently won’t work with multi-site. As far as the cache I’m not sure if the memcache makes use of the WP_CACHE constant or not. I could be wrong. However it probably is related to a plugin that is enabling that code to be executed in the WP Core….


Thanks so much for your help here!

I’m also having issues with the non multi site, but I will work those out in another thread. Also I have disabled all the plugins (by renaming the folder) and it is still the white screen so not sure if it is plug in related??


Plugin Author Cory Lamle


Yeah if you want to start a new thread that may be better this one is formatting strange in my browser anyways…

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Memcached issue after migrating site’ is closed to new replies.