Support » Plugin: Paid Memberships Pro » Membership start date error

  • After updating the plugin, and adding and then removing days later the membership cancel gist, I have several users reporting that they can’t access dripped content that they already had visible…I would really appreciate some support, this is some serious trouble for me.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Two more clients pissed off today…bump…

    Plugin Author Jason Coleman

    (@strangerstudios)

    Which gist do you mean by Membership Cancel gist?

    How is your drip feed setup? Are you using PMPro Series?

    Are the users losing access after canceling, when they should have access through a pay period or to old content?

    Hi:

    The membership cancel gist: I implemented this:

    https://gist.github.com/strangerstudios/6169167

    And, it could be me, but I noticed an increase in cancellations after new memberships, so I removed the patch.

    I’m using PMPro Series. My drip feed is like follows: I have 12 categories, every one drips 1 new video each month. But suddenly, I started receiving mails from clients stating that they lose acces to content that they already had; for example, they could see video #7 (in any of my categories) and now they can only see #6. I’m temporarly patching this by adding several pmpro_member_startdate() filters (one for each member that reports the same problem).

    Anything else, I’ll be happy to provide.

    Plugin Author Jason Coleman

    (@strangerstudios)

    Thanks for the info. I’ll test this out. One thing that could be related is that we’ve updated how categories are set on the edit membership level page. It’s possible these settings were somehow corrupted on your site. Edit your membership levels and make sure the appropriate categories are set. If not, let me know here.

    Ok, I’ve edited all and saved them again just in case. Adding some more info, one thing that puzzles me is that the start membership date is correct in the membership user listing, but somehow it miscalculates the days (I’m supposing this is the problem) and shows less content that it should…I even peeked at the database and code and everything seems right…checked server version also, correct.

    Didn’t work…I keep getting emails on a daily basis from people that somehow lost their series progress..so far I’ve adjusted manually 23 users.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Membership start date error’ is closed to new replies.