WordPress.org

Support

Support » Plugins and Hacks » Membership 2 » [Resolved] Membership Not Properly Masking Media Location For Content Linked In Posts

[Resolved] Membership Not Properly Masking Media Location For Content Linked In Posts

  • I have set up membership under “Download / Media Options” to mask the url of where media is stored.

    I have left “default” as the name for the protected group, and have not changed the actual location of uploads in wordpress. It is still “wp-content/uploads”

    And yet, even with these settings, and assigning a PDF file I have uploaded to the “default” protected group, when a subscriber hovers over the link to it in a post, the url is not masked. It shows the actual location of the file, rather than using the “downloads” moniker that is suggested for the masked location, which can then easily be copied and accessed directly outside of the website.

    What am I doing wrong?

    I have two levels of access configured, “visitor” and “subscriber.”

    I have tried adjusting the permissions of these levels, both positive and negative, with the “downloads” option, to see if that made a difference, but it doesn’t.

    What I’m wanting… is for a subscriber with access to be able to click the file in a post and open it, without knowing the actual location of the file on the server.

    I thought that was the purpose of masking the url.

    Can someone help me, if they have encountered a similar problem? I would sincerely appreciate it.

    http://wordpress.org/extend/plugins/membership/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Mike

    @michael-copestake

    WPMU DEV Support Staff

    Hi @joshjosh

    In your Downloads/Media tab which protection method have you chose?

    Complete would be best I think, also have you ensured that the spelling of “default” is exactly as it is in the media library? Maybe add a new category and add that to the protected list too.

    Let us know how you get on please.

    Hi Mike. Thanks so much for responding.

    I have actually tried all 3 protection options. But, none of them seem to mask the URL.

    I don’t actually set the spelling of the folder in the media library. I actually will give me the option to select that group when I go to insert a link to the media in one of my posts, thus asking me if I’d like it be protected. I also have the option to assign that protection group to the media when viewing it in the media library. So, I don’t see how I could adjust the spelling outside of the Membership plugin.

    I did try to set another protected group, titled “documents,” but I am still getting the same result.

    Here are some screen shots so that you can see what my issue is for certain:

    This is what the post looks like on my website. I am logged-in as merely a subscriber, and when I hover over the link to download, it is clearly showing the entire pathway for the document, and where it is hosted on the server. So, it is clearly unmasked:

    Website Post With PDF file download I’m trying to mask:

    Here’s what the settings look like for the post when creating it:

    Here are the specific settings in the media library for the PDF file itself, which I am trying to protect:

    These are my permalink settings:

    WordPress media settings:

    Every screen and section of the Membership Plugin Settings:

    Will you kindly take a look at what I’ve got here, and let me know what can be done? When logged in a simple subscriber, with no admin function, I view this page and the actual link is not masked, but is rather exposed.

    I’m trying to figure out how to get the masking to work.

    If you need any other info from me, please do not hesitate to ask.

    Thanks so much in advance for your input!

    Josh

    ellbristow

    @ellbristow

    WPMU DEV Support Staff

    Hi @joshjosh,

    You have manually added that link to the post. If you manually add a link, Membership will not rewrite it, you would need to recreate the link to point it to the masked location.

    As the plugin states (per your screenshots), “If a user determines a iles actual location on your server, there is very little we can do to prevent it’s download”.

    Hey there.

    We haven’t heard from you in awhile, so I just wanted to check in to make sure all was good.

    This thread was marked resolved, but please, if you still need help then just respond and open it back up. We can then take it from there. 🙂

    Hope you have a fantastic day!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Membership Not Properly Masking Media Location For Content Linked In Posts’ is closed to new replies.
Skip to toolbar