Support » Plugin: Membership 2 » Membership 2 not recognizing Admin Accounts

  • This issue seems to have started around the time WordPress was updated to 5.x so I am wondering if there needs to be an update to the Membership 2 plugin?

    I have thought about how to capture and how to replicate the problem but it is so random that I am not prepared to fire up Streamlabs for a recording to show it nor can I find a method to replicate the problem.

    It is just one of those annoying things that happen with the admin accounts. I go to my site and see that I have been logged out (the WP admin bar is not showing). I have the Membership 2 sidebar widget on the sidebar and I use the LastPass chrome browser extension that auto-fills the login details. I click login and get a return message that my login has failed. I then attempt a login manually by typing the complex password and I still get a failure message. At this point, I then manually type in the URL for the admin panel (http//xxxxxx/wp-admin/) and I get a WordPress login page. I then let LastPass fill in the details and presto! I have logged in again.

    At this point, I can then use the sidebar Membership 2 login and perform login and logout functions correctly and repeatedly. I can only assume this is a desync issue between the Membership 2 user database and the WordPress user database.

    I also see errors in the logs indicating other users are having similar authentication issues and when they email me, I simply instruct them to perform the same login process I follow which rectifies the issue.

    Sorry, I can’t be more helpful. This has been happening since the WP5.0 update so I was assuming it was simply the fact that the Membership 2 plugin was out of date.

    Has anyone else seen or experienced this issue?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @popekael,

    We didn’t have any similar reports since the 5.0 release so this looks like something specific on your end.

    I have asked a couple of my colleagues to test this with me so we have tried to log in to your site on multiple browsers with different OS and none of us could replicate this issue.

    I wouldn’t say that this is caused by DB desync but that there’s rather some caching, either from plugin or on server, that’s causing it.
    Can you try clearing and disabling any of the caching that you have and see if you the issue happens after that as well?
    Also, do you have any kind of asset optimization plugins and can you try disabling those as well?

    Do you have a staging site with the same setup where you could do some additional tests with other plugins disabled, because it’s possible that something else is conflicting on WP 5.x and causing further issues?

    Do you have any errors in browser console or in your debug log when this issue happens?

    Cheers,
    Predrag

    Thanks for getting back to me Predrag.

    As I’ve indicated, It is just so random that I can’t find any method to reproduce the issue as in, click this and that will happen.

    I do run a cache on the site and I am also routing through Cloudflare. The total randomness of the issue is not worth disabling these cache systems in the vain hope that I will randomly reproduce the issue. It does get me thinking about how I might test it on the next occurrence though 🙂

    The main problem I have faced in the past is that when the problem does occur, I’m usually in a hurry to get a blog post published and as I’ve indicated, I know how to get around the login problem fairly quickly, so that’s how I work around it.

    Anyway, I’ll report any findings here if I can narrow the issue down.

    Plugin Support Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @popekael,

    Such issues are hard to debug as we would need to see it in action, or at least try and pinpoint the cause of it.
    If you have an option of creating a staging site where you can disable caching and test this there that might help us.
    If you try to login to staging site each time to do it on live, but don’t ever experience this problem we could be pretty certain that it’s caching causing it.

    If you do manage to get any additional information do let us know here so we can check it out further.

    Cheers,
    Predrag

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.