Support » Plugin: BuddyExtender » Members Slug Bug

  • Daniel Alvares

    (@portuga_daniel)



    Hi,

    I selected the option “Remove members slug from profile url” and it works fine except that it gives me an 404 error with blog posts.

    We have this permalink: website.com/author/postname

    Tks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Michael Beckwith

    (@tw2113)

    Good day @portuga_daniel

    I’m not sure it’s necessarily a bug, but more a conflict in query args and what WordPress thinks it needs to be querying for.

    I was able to recreate the situation with my local development site, and from the looks of things, the 404ing page is thinking it should be grabbing a specific settings page, but since it’s not finding one, it’s returning a 404 error. This is because with this configuration, both BP pages and single post permalinks start with usernames. Anything you could put in front of the post urls would break this mix and get both loading.

    Daniel Alvares

    (@portuga_daniel)

    Tks for the super fast response.

    Is there anything we can do to workaround this situation and keep the current permalink?

    Plugin Author Michael Beckwith

    (@tw2113)

    None I know of that have been tested. You could try to set the correct query parameters via something like the pre_get_posts filter, but otherwise my best suggestions are either re-add the members prefix for BuddyPress profiles, or tweak the permalinks rules.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.