Support » Plugin: Ultimate Member - User Profile & Membership Plugin » Member cannot edit custom form fields in profil

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @josee225,

    According to your screenshots you’ve added some fields to the user meta, please don’t forget to add the same fields to the profile and registration form so users can fill in them. It is not possible to edit fields directly inside the user meta.

    Regards.

    crackedvesselcom1

    (@crackedvesselcom1)

    Hey, I don’t work for this company, I’m just a user who came here to ask a question, but since I had this issue when I started, and there was no good explanation in the documentation, and the answer you got isn’t very detailed, I figured I would post.

    You have to select which fields you want to show on the profile by creating a custom profile form in the form builder. The easiest way I found to do this was to duplicate the registration form, change the form type to profile, and delete the things you don’t want to be on the profile. Choose “yes” on the right sidebar where it asks if you want to customize. You can select whether you want these items to show on the profile all the time or only in edit mode on each individual widget. Don’t forget to change the profile on the settings to the new page you’ve made containing the shortcode for your newly designed form.

    The fields will appear as information, with the boxes closed, in viewing mode, and they will open up for editing in edit mode. Note that you can’t edit the user name and though it may look as if the email has been edited it actually hasn’t.

    Forget about the user meta, it’s a viewing thing, not an edit thing. All it does is make the things you select show up in tiny print at the top of the profile.

    webdev

    (@webdevmelb)

    thanks however my custom fields are still not showing in the User Profile. In Ultimate Member I have added the custom fields to both the Registration Form and the Profile Form. On the right hand side I have selected YES for customise this form. Under Users there is an Ultimate Member heading but nothing is under the heading – none of my custom fields.

    I’m really surprised it’s so hard! I am simply wanting to create a searchable member listing where the member profiles have custom fields! Right now the search options have stopped displaying and the profile listings custom fields can’t be edited. Can I pay for support without having to purchase all the plugin pack so that I can get this organised?

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @webdevmelb,

    Do you use unique profile forms for different user roles?
    Have you selected any user roles in “Make this profile form role-specific” on the right side of the page? If you use this option you have to create profile forms for every user role and add it to your User page. Basically, this means that for different user roles the unique profile will be shown, moreover, if you don’t have a profile form for the e.g. admin user role the User page will be empty.

    Regards.

    webdev

    (@webdevmelb)

    this site is for listings created by the admin of the site and that can not be edited from the front end of the site. Users do not register for the site.

    I have created a user role for this group of users.
    I have created a new profile form and selected “yes” for apply custom settings for this form and selected the new role.

    1/ On the frontend of the site when the user profile is selected it is blank ie none of the fields added show (email address, phone etc)??

    2/ Under wp admin User – none of the custom fields added show (ie data can not be added). There is a heading for Ultimate User but no fields show under the heading??

    I feel like what I am trying to do is very easy – add user fields to the user profile!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Member cannot edit custom form fields in profil’ is closed to new replies.