Support » Fixing WordPress » Megadropdown Sub-Menu works locally, but not on remote server

  • Resolved jefcre


    After building out my CMS-geared theme locally on a MAMP set-up with everything working perfectly. I decided to move it up to a remote server for testing, everything moved along smoothly, all custom-field data, all pages, etc. BUT for some reason, the jquery mega dropdown menu I have running under the main horizontal nav just isn’t showing.

    Absolutely bizarre because on the MAMP install, it works like a charm. It queries the child and grandchild pages of the main top level pages and lists them beneath in a div that is hidden until rollover. Has anyone encountered this sort of weirdness?

    The navigation is pulling the right child links and formatting them correctly, you can see it when you “view-source” but they are just not displaying below the nav like they should.

    I’m pretty sure its not a “overflow:hidden” or z-space issue as I’ve tried just about everything to troubleshoot those, but any help would be greatly appreciated. I’m pulling my hair out.

    The testing site is here: if that is of any help. Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • My first step in any Jquery related issue is to see if jquery is activating. Try entering alert('Jquery Lives!');` just after your function in the header. If you get the “popup” alert, at least you know jquery is properly loading.

    Also, are you inserting Jquery directly into your header.php or using wp_enqueue_script in your themes functions.php? The latter is the best way, in my opinion, to safely implement jquery. You can find out more here: wp_enqueue_script

    Try all that, and comment back and let us know if it worked or not!

    JQuery Lives alert worked no problem. I switched the scripts to call up jquery via wp_enqueue_script and still no luck. Thanks for offering the the suggestions though. This is so strange.

    I got it. It wasn’t anything to do with how jquery was loading!
    after firing up firebug and checking my local version against my remote version, i could see that the hoverIntent plug in I was using wasn’t affecting the objects i had it set to target on mouse over.

    further inspection showed the reason for the above being that my permissions for that file and that file only were set to “600” instead of “640”. How that happened? who knows. I’m just glad it’s sorted.

    I had a similar problem. I am so glad I found this thread otherwise I would still be pulling my hairs out. 🙂 I changed the file permissions for my 2 jQuery scripts from 644 to 755 and now everything works fine. Thanks @jefcre!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Megadropdown Sub-Menu works locally, but not on remote server’ is closed to new replies.