Support » Themes and Templates » Mega problem with theme switcher after installing one “last” theme

  • I downloaded and installed the theme from the competition site day before yesterday. Nice theme. But. I didn’t choose it until yesterday evening and immediately set itself as the only selected theme – ever. It refused to allow selection of another theme from the dropdown. I couldn’t change anything about the theme: I took the dropdown out of the sidebar (replacing it with the standardized list), but the dropdown was still there. I took the theme switcher call out of the sidebar completely – it’s still there. I finally “broke” the theme by getting rid of the stylesheet which at least allowed me to load another theme when navigating to the page, then I took theme switcher off completely from all the themes, deactivated it, and now just chose a theme in Presentation. Which works. Sort of.

    What doesn’t work is that navigating to admin from the blog, while not a problem, upon return to the blog sends me back to the index.php – unstyled because the stylesheet isn’t there! And this is a with all of the stuff I took OFF still there…. in order to get back to the other theme, I have to click on the header link…. If I rename in the themes folder so that it doesn’t show in Presentation, I STILL (even after clearing cache and hard refreshing a million times!) get the unstyled 3/20 index.php. If I delete the folder entirely, I still get the same index.php. I have tried reinstalling the theme with nothing in the way of plugins in the sidebar.php and setting it back to Active Theme in Presentation. The page now displays properly styled – but still with the plugins including the theme switcher dropdown! If I then click on one of the themes displayed through the dropdown, the theme displays again, WITHOUT the plugins. But then if I choose another theme as Active in Presentation, it reverts to the original theme index.php page, WITH the plugins.

    Really strange. I’m really baffled. I have no clue where to start to track this one down…. the even stranger thing is that when I view source on the unstyled index.php, it shows the date as 3/20/05, and the stuff that’s not there any more at all: weather icon, theme switcher, and Shire Reckoning – and then when I’ve reset as the Active Theme, clicked on a different theme in the dropdown, and then check source on the redisplayed page, it’s the sidebar.php WITHOUT the plugins.

    Logging out: tried that too. Logging back in as a test user shows just the theme the way it should display, with no plugins. Logging out then back in as “my admin persona” show the page the way it should be UNTIL I go to Presentation to change the theme. Then going back to the site from the link at the top sends me back to the page WITH the plugins, and the “broken” themeswitcher….

    I’m sorry this is so long. I probably still haven’t made much sense. URL to page.

    [One last thing: clicking on the header link from the page goes to whatever the currently selected Active Theme is…. in the current instance, Quentin…. – so maybe that’s what anyone will see, I don’t know *sigh*.]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Have you tried deleting the cookie in your browser for your site?

    Oh yeah. That and about everything else possible to do. I deleted every session and persistent cookie. I went into temp i’net files and cleaned house (wasn’t much but still….) Anyway, it’s fixed. I installed a new instance of wp with a new database, and transferred the pertinent info into the table structure. So I still have the posts and comments, but no themes except the two “vanilla” ones, and no plugins.

    So now I can go back and put things where they were before. Except for the “one last theme”…. *sigh* I quite liked it too! I guess one of these days in my copious free time around Access databases and NWN modules I’ll have to do my own template. Seems silly to spend the time messing about when there are so many great ones available though!

    Thanks for the thought, Kafka!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Mega problem with theme switcher after installing one “last” theme’ is closed to new replies.