WordPress.org

Support

Support » How-To and Troubleshooting » MediaElement and WP 3.6. issues

MediaElement and WP 3.6. issues

  • Hi. In this site and in this post http://exodusinteractiveforum.com/test-post-for-embedded-audio/ I have used the WP 3.6. native audio system which uses mediaelement. Now, in the mediaelement core in WP it has the Google Analytics scripts to track many things for Events. i.e. Duration, Play, etc.

    However, these data after I did several tests do not pass to G.A. Events. I use G.A. Universal. I did another test using Haiku player and Haiku sends Play button clicked/Download data but only these.

    How is this solved?

    Additionally: After running a number of tests for cross platform functionality here is what I get (same url as above)

    1. Problems with iPad and Android phone. Of the file podcasts that are posted, only the last one plays. (It is set to auto start when the page is loaded; maybe that has something to do with why the first four don’t load.) I could not click on the first four to get them to play. On the iPad, they showed up as 00:00 / 00:00. On the Android phone, they initially showed up as 00:00 / 00:00, but after I reloaded, they posted the correct number of minutes as the second number 00:00 / 32:67, but I still could not get it to play. I did let the last podcast run on each of them for your test purposes.

    2. All of the files loaded properly in IE and Chrome. In IE, the first file started playing automatically, but the other files still loaded. in Chrome, the fourth file start playing automatically, but the other files loaded as well. I played a few minutes of each.

    Is there any solution for the Events tracking and the cross platform issues?

  • The topic ‘MediaElement and WP 3.6. issues’ is closed to new replies.
Skip to toolbar