Media Vault
Media Vault Activation Helper and bitnami (2 posts)

  1. grich
    Posted 1 year ago #

    thanks for a great plugin!
    But I have a problem when installing it.

    I'm using a bitnami vm installation.
    They've changed the settings (for security reasons) from the htdocs folder to a different place (example: /apps/wordpress/conf/httpd-app.conf. more about it: https://wiki.bitnami.com/Components/Apache/htaccess_configuration)
    also AllowOverride is set to None as recommended by "Apache Software Foundation" (so maybe that has to do with it)

    After installing the plugin I got to "Media Vault Activation Helper" - I guess because that there is no .htaccess file in the htdocs.
    I've added the lines it says to my httpd-app.conf file:

    <IfDefine USE_PHP_FPM>
        <Proxy "unix:/opt/bitnami/php/var/run/wordpress.sock|fcgi://wordpress-fpm" timeout=300>
    <Directory "/opt/bitnami/apps/wordpress/htdocs">
        Options +MultiViews +FollowSymLinks
        AllowOverride None
        <IfVersion < 2.3 >
        Order allow,deny
        Allow from all
        <IfVersion >= 2.3>
        Require all granted
        RewriteEngine On
        RewriteBase /wordpress/
        RewriteRule ^index\.php$ - [S=1]
        # Media Vault Rewrite Rules
        RewriteRule ^wp-content/uploads(/_mediavault/.*\.\w+)$ index.php?mgjp_mv_file=$1 [QSA,L]
        RewriteCond %{QUERY_STRING} ^(?:.*&)?mgjp_mv_download=safeforce(?:&.*)?$
        RewriteRule ^wp-content/uploads(/.*\.\w+)$ index.php?mgjp_mv_file=$1 [QSA,L]
        # Media Vault Rewrite Rules End
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule . /wordpress/index.php [L]
        <IfDefine USE_PHP_FPM>
           <FilesMatch \.php$>
             SetHandler "proxy:fcgi://wordpress-fpm/"

    and clicked on the enable button, but I still get the following error message:
    Media Vault could not be enabled because the rewrite rules have not been set up correctly. Please verify that you have gone through and correctly completed each of the steps below and try again.

    how can I make it work? I really liked ur plugin.

    Thanks in front!


  2. jlmaners
    Posted 1 year ago #

    I'm not sure if this will help, but we recently got MediaVault working in our httpd conf by slightly modifying the rules. We did this outside of a directory block, so not sure if that will change things.

    Our Updated Rules:

    # Media Vault Rewrite Rules
    RewriteRule ^/(?:[_0-9a-zA-Z-]+/)?wp-content/uploads(?:/sites/[0-9]+)?(/_mediavault/.*\.\w+)$ /index.php?mgjp_mv_file=$1 [QSA,L]
    RewriteCond %{QUERY_STRING} ^(?:.*&)?mgjp_mv_download=safeforce(?:&.*)?$
    RewriteRule ^/(?:[_0-9a-zA-Z-]+/)?wp-content/uploads(?:/sites/[0-9]+)?(/.*\.\w+)$ /index.php?mgjp_mv_file=$1 [QSA,L]
    # Media Vault Rewrite Rules End

    To clarify, all of our rewrite rules are not inside of a directory block but rather just a <VirtualHost> block.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Media Vault
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.