Support » Plugin: Frontier Post » Media Uploading but not showing in frontend

  • So I completely love this plugin and what it’s allowing me to do on my site. Issue now is, no one (including all admin) can upload pics via the media button from the frontend.

    So lets say I want to upload a picture from the frontend. I select media and all and it lets me upload. However, the text box freezes and I can’t go on typing or even view the pictures that uploaded.

    Help please!

Viewing 15 replies - 1 through 15 (of 19 total)
  • Update, I’ve found that when I limit the editor type to “minimal visual” everything works well in the frontend, but when set to “full editor” that’s when I have the above stated issue. I also found that the issue is more than the picture not showing, basically typing into the the textbox is impossible.

    For now I will stick to the “Minimal Visual” as this solves my earlier stated problem. 🙂

    Plugin Author finnj


    There must be some kind of a conflict with one of your other plugins, can be difficult to find though…..

    I have seen this issue with editing problems previously, but only on my iPad, not from a laptop – But I could select the Text tab to edit the text, does that work for you ?

    Please supply a link to your site.

    one thing you could test (remember to take a copy of the wp-config.php file before you make changes:
    Open wp-config.php and add
    define('CONCATENATE_SCRIPTS', false);
    above the

    /* That’s all, stop editing! Happy blogging. */


    The text tab works at times, and other times it doesn’t.

    My site

    I’ll test what you’ve suggested but that’ll be when I get some help with that. I’m very new to all of this and for now everything’s working so don’t want to mess anything up.

    PS The support you’re providing on this plugin is fabulous! Haven’t been as successful with a lot of the other plugins I’ve got installed. Thanks a bunch. 🙂

    Plugin Author finnj



    Nice site 🙂

    Without being able to access the front end posting page, I have a couple of ideas

    I suspect your issues relates to a ajax conflict – I like the recent posts scrolling down in the sidebar, but this could be the cause of the conflict – you could try and disable this for the Frontier Post page.

    Try the following:
    1. Edit the page (you can find the name in settings/frontier post)
    2. Change the Template to a template without sidebars (different name for each theme)
    3. Disable comments for this page.

    In addition to this, I can see you are using a voting plugin – I had one installed such a plugin, but it messed up my sitenso I deleted the plugin, which one are you using ?

    Ok I’ll try what you’ve recommended but my site is down at the moment (urghhh)

    Plugin Author finnj


    Did you have a chance to test the suggestions ?

    hey ya!

    not yet but will let you know how it goes..

    Hey! Got an issue from a user of my site. Haven’t been able to replicate the issue yet, but thought I’d let you know. Pls let me know how I can attach the screenshot for your viewing… Thanks!

    Plugin Author finnj


    There are some sites out there where you can store the screen shot for free, and then put a link to the image here

    Or you can send it to me:

    Send them to wp frontier 99, and then at gmail
    (No spaces)


    Plugin Author finnj


    It seems like the user is trying to upload images to a page, Frontier Post is designed to add/edit posts, not pages…..

    Also image file names seems to be very long, could be rejected by wp or server, might try to give the user access to the backend temporarily (not as admin, with current role)

    What role does the user have ?

    hey ya

    so i did get around to the first suggestion, which was to remove the scrolling stuff. i just changed the page to be fullwidth so nothing else appears on that page. the issue still persists.

    The users have the frontend author role, and uploading images via the frontierpost page to my wp dashboard. I wasn’t getting the error before but now I get it too, “An error occurred in the upload. Please try again later.”

    also, the “Max age in days to allow edit of post:” is this before or after the post has been published?

    Thanks again for all your support!

    update: I’ve observed the error only occurs when posting as a “frontend author”… Admin users do not get the stated error…

    also in google chrome, the dragbox buttons do not show to resize attached pictures. tried and it shows in firefox and IE…

    Plugin Author finnj



    As for the upload error, Do you have any plugin that restricts access to back-end ? I have seen this issue with “Theme My Login” plugin as described under FAQ’s. Apart from that, I am out of ideas, sorry

    Max days should be days from publish date (I am using the post_date field).

    As for the Chrome/IE difference – There is no Java script in Frontier Post apart from what comes out of standard WordPress related to the editor and image upload, so it should be the same with standard WordPress

    Sorry I cant be more helpful….

    Thanks for all your help and support, Finnj!

    You were right! I did have a back-end restricting plugin and once i deactivated it, frontier author could upload media.

    Everything works perfectly now, but frontier author cannot seem to be to delete draft/pending review posts even though the delete option for frontier author is enabled. I think it could be a plugin conflict again because this was working just fine. I’ve tried deactivating suspected culprit plugins but nothing has worked so far. If you’ve got any suggestions pls let me know! Thanks

    PS If you did make a premium version for this plugin (and it’s reasonable priced) i’ll pay for it! Fabulous plugin this is…

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Media Uploading but not showing in frontend’ is closed to new replies.