Support » Fixing WordPress » Media Upload:Failed to write file to disk

  • Resolved FauxReality

    (@fauxreality)


    I run FauxRealityEntertainment.com. I suddenly cannot load images. I get an error code that says : “Failed to write file to disk” HELP! As a blogger, this is extremely important to resolve. I have been unable to do any new posts as a result!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Josh

    (@josh401)

    Moderator and Editor Customizer

    I would first check my WP folder permissions. It is possible the “wp-content/uploads” directory has the wrong folder permission.

    JOSH! I love you! It worked. It’s a purely platonic thanks for helping kinda love. lol RESOLVED!!

    Josh

    (@josh401)

    Moderator and Editor Customizer

    Lmao. Completely understood!!

    My absolute pleasure!

    I’m also in the state of not being able to upload media. I checked my Upload folder permissions and they’re set to 755, wherein a user should be able to Read, Write, and Execute.

    Any other ideas? Server related issues are where I stumble about in the dark and I really appreciate any guidance.

    Same here! I checked my permissions for wp-content/uploads, it’s 755 as well, but I get an “HTTP Error” which isn’t very specific, every time I try to upload images.

    @jaybarrow I fear that you and I are destined to go the route of systematically deleting and re-installing to get things going again as per:
    http://wordpress.org/support/topic/widgets-in-sidebar-gone-widgetsphp-line-80-error

    I’m going to attack the “includes” folder first and hope for the best. If anything works I’ll be sure to report back.

    So, I disabled plugins, deleted a few that I wasn’t even using, downloaded a fresh backup of the entire site just in case, and was prepared to lose the entire day to troubleshooting.

    Then it started working again.
    I have no idea why. I’m going to back away slowly and hope that it continues working.

    So, the only advice I can give to others is to attack the plugins first as a possible incompatibility issue.

    I have another website run by WordPress and thought I’d check it out, and I’m having the same issue there, too! It must be my host, Dreamhost. Things aren’t working anymore.

    Be sure to click “apply to enclosed items” when setting the permissions of the uploads folder. That’s what did the trick for me.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Media Upload:Failed to write file to disk’ is closed to new replies.