Support » Fixing WordPress » Media Uploader Stuck at Crunching

  • I have had this problem for the last few days and I am baffled. When I try to upload a 4MB (or anything larger) .mp3 in WP, the progress bar gets stuck at “crunching…” When I try the browser uploader I don’t get any progress at all and it sends me back to the original uploading page. I don’t get any errors with either methods.

    Uploading works fine with older versions of WP, but as soon as I update to 3.3.1 I have this issue.

    Here are the things I have tried to debug:

    • I have tried this issue on different browsers – FF, Chrome, & Safari (on mac) and FF, Chrome and IE (on PC).
    • I have tried deactivating all plugins and switching to default theme
    • I have installed a fresh, out of the box WP install with the default plugins and theme
    • I have cleared my cashe, cookies, reset my router, reset my browser and rebooted my computer.
    • I have been on tech support with my hosting company
    • I have disabled mod_security in the .htaccess file
    • I have double checked the max_upload size (it is set at 64MB)
    • I am able to upload smaller images and it works fine

    I am able to upload the files via FTP. Also, even though the image uploader gets stuck on “crunching” the files usually upload to the server. I can see this by FTP-ing to the server.

    The only thing I can think of is that this could be a bug with 3.3.1, but I have been doing a ton of searching around and I can’t find anyone with the exact same issue as me.

    If anyone has any ideas I would love you forever.


Viewing 2 replies - 1 through 2 (of 2 total)
  • If anyone stumbles upon this, the problem solved itself for me and a few others. It looks like it was a change with our hosting company. If you are having a similar problem check with your hosting provider.

    Hi Keith,
    I have the exact same problem. I am on WP 3.4 and did most of the same steps you did to try to debug. All the .jpg files are there in the wp-content/uploads/2012/06 folder when I use FTP to look, however, the WP Media Library shows a file with (no title) and only a View link option (no options to Edit or Delete Permanently, like the media library is supposed to show). Also, I cannot upload even smaller images via the Media > Add New interface, although even small images (1KB favicon) appear when you view using FTP, even though one sees the “Crunching” message forever – the crunching process never seems to complete.

    I have two sites on the same hosting provider: the site with the above problem was cloned from the site that does not have the problem. I used BackupBuddy 3.0 with the importbuddy.php script to do the cloning – using a file created from the origin site that works correctly for the Media Library.

    One other symptom: when I create a New User in the Users section, there is no Username, Name, Email shown for the new user; and the Role shows as blank, even though I assigned Editor role to the new user. I get notified via email about the New User Registration, but the Username and E-mail fields on the notification are blank. This symptom only happens on the cloned site, not on the original site that the site template was made from. Both sites are running WP 3.4.

    So, in my case, since both sites are on the same hosting server, I don’t think my situation has do to with a change with my hosting provider.

    I have deactivated all plugins except akismet and am using the TwentyEleven v1.4 theme and have the above two problems, although I had the same problems with another Theme, so I don’t think it is theme related.

    Any ideas for solutions or further debugging? Is there a good utility that can compare files between two different WP sites (running on the same host), so perhaps I can detect any differences between the two sites?


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Media Uploader Stuck at Crunching’ is closed to new replies.