WordPress.org

Support

Support » How-To and Troubleshooting » media uploader not working on 3.5

media uploader not working on 3.5

  • I upgraded to 3.5 last week and discovered that I could no longer upload files via the media uploader or from the post editor. I have tried many of the solutions suggested here, and I can’t get any of them to work for me.

    The site is hosted by GoDaddy.

    What Happens:
    When I try to upload a photo, either a message saying “HTTP Error” appears above the upload form, or the uploading progress bar turns into an error saying “IMG_NAME has failed to upload due to an error
    Failed to write file to disk.” Which error occurs seems to depend on the size of the image: Small files get the failed to upload, larger ones get the HTTP Error.
    Using the browser uploader gives an “Internal Server Error” with any file.

    What I Have Tried:
    Deactivating all plugins and reverting to Twenty Twelve theme.
    Doing a fresh install via FTP.
    Adding
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
    to the .htaccess file.
    Setting permissions to 755 for wp-content and uploads.
    Setting permissions to 777 for wp-content and uploads.
    Increased the memory allocated using define(‘WP_MEMORY_LIMIT’, ’64M’);
    Set the temp dir using define( ‘WP_TEMP_DIR’ , ABSPATH . ‘wp-content/’ );

    I pretty much did everything I could find that had to do with 3.5 media uploader problems, but nothing has worked.

    I would really appreciate any suggestions or other help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I found another error which may be helpful. When trying to connect to Jetpack, it says “Your website needs to be publicly accessible to use Jetpack: site_inaccessible Error Details: The Jetpack server was unable to communicate with your site [IXR -32300: transport error: http_request_failed Couldn’t resolve host ‘luellajune.com’]

    I once got scolded for sharing this, but I now bypass all of that brokenness by uploading via FTP and then using the Add From Server plugin to register my uploads.

    Well it does work quite well. Thanks for the tip. I would still like to find a solution to get the media uploader working if possible.

    Update: Jetpack connection began working a bit ago. Didn’t do anything, just tried later and it worked. Still no media uploader though.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘media uploader not working on 3.5’ is closed to new replies.
Skip to toolbar