Support » How-To and Troubleshooting » Media uploader not working after 3.3

Media uploader not working after 3.3

  • Jozef



    After upgrading to 3.3 my media uploader no longer works. If I go to add a new image, the dialog appears, but without the drag and drop function and if you go to click the select files button nothing happens.

    After snooping around with firebug i get this error on the upload page: “Uncaught ReferenceError: jQuery is not defined” “load-scripts.php: 10”

    I can also see that jQuery doesn’t seem to be loading which I presume is the error, but I have no idea why! I have tried the usuall deactivate all plugins etc with no luck.

    Any help would be appreciated



Viewing 15 replies - 1 through 15 (of 19 total)
  • Moderator kmessinger


    Have you worked all the way thru this, http://wordpress.org/support/topic/troubleshooting-wordpress-33-master-list?replies=5 ?

    especially the javascript errors part.



    yeah went through it. I’m not getting the javascript bug they show there. going to http://example.com/wp-admin/load-scripts.php?load=jquery (obviously with my site instead of example.com) brings up the jquery script like it should.

    Drew Jaynes


    Docs Czar


    Your issue might be theme related. Are you still having this problem if you switch to TwnetyEleven?



    Cheers drew it works with twentyten! Obviously I need to find out why my theme is incompatible though.

    Its uses <?php wp_enqueue_script(“jquery”); ?> in the header and:

    function my_init_method() {
    wp_deregister_script( ‘jquery’ );
    wp_register_script( ‘jquery’, ‘http://ajax.googleapis.com/ajax/libs/jquery/1.6.4/jquery.min.js’);

    add_action(‘init’, ‘my_init_method’);

    in the functions. Would i be right in saying that this is overiding the version of jquery the dashboard is using and it needs a newer version?

    I tried switching to twenty_eleven but that does not help to solve the problem. It still opens the media chooser but every click on file chooser or show details for already existing pics does not react on click.
    any tip to solve this?

    You have to have the original WordPress themes installed Along your Custom Theme

    I am having this problem too and have yet to solve it. I do have the original WP themese installed like abozabra suggests, but that makes no difference. I also deactivated all plugins and I still get the “ReferenceError: jQuery is not defined” error.

    I am using a custom theme that I built from scratch (html templates that i pasted php snippets into), but I’m not a programmer and scripts are kind of mysterious for me. Jozef, I think you are on to something regarding a code update that may be needed somewhere in my functions file. right now i have this:

    function hls_init_jquery() {
    add_action('init', 'hls_init_jquery');
    add_action('wp_print_scripts', 'hls_set_query');

    I have seen that others are facing this issue and would love to get some advice if anyone knows what to do. please!

    Bump … media uploader not working, ‘add from server’ won’t work.

    It comes up with error re parent directory permissions … but that is not it.

    Even if I make it 777 right the way up, which I loath to do, it does not make any difference.

    What did they change to make this happen?

    It has nothing to do with plugins.

    I disabled the lot and come up against the same problem and the same error message.

    “xxx.jpg” has failed to upload due to an error
    Unable to create directory /usr/home/xxx/public_html/wp-content/uploads/2011/12. Is its parent directory writable by the server?

    All directories are currently 777
    What is wrong?

    Anyone with any idea of what caused it?

    It is especially disappointing that this was not fixed in the 3.3.1 update.

    i agree with photocurio. this is still a major issue and has held up production on my project for over 2 weeks now.


    What do I need to do with my custom theme in order for it to support the new uploader?! Or at least provide a workaround so I can add images some other way PLEASE!!!

    My jQuery is just in my header like so:

    <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js" type="text/javascript"></script>

    I have the same problem, and also a similar one when trying to insert a link. I use Thesis for theme.

    Moderator kmessinger


    You can always upload images via ftp. They won’t be listed in media library but you can still put them into wordpress.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Media uploader not working after 3.3’ is closed to new replies.