WordPress.org

Support

Support » How-To and Troubleshooting » Media uploader not working

Media uploader not working

  • I am running the Mystique theme, WordPress ver. 2.9.2 and up until a few days ago all was fine, I went to add a new post and include some photos, via the four upload/insert buttons on the dashboard. Click on them an nothing happens. I can right-click and open them in a new tab (I am using firefox) but obviously this doesn’t really work.

    I thought it may be a flash error, so first updated flash and then tried two other machines, all with the same result. I also contribute to a friends wordpress, who runs his site with same version, but uses the iNove theme. Now, I’ve just posted on his site and the upload/insert buttons work fine, ruling out a problem with my machine.

    I don’t know what I’ve done, since I’ve made no changes, or what else could be going on. It’s incredibly frustrating since it’s rare for me to post without any photography or media.

    Any help would be gratefully received!

Viewing 10 replies - 1 through 10 (of 10 total)
  • esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems?

    I tried deactivating all the plugins to no joy. The theme has been running fine for weeks with no problems. When I click the button to add media, I’m reluctant to change theme.

    esmi

    @esmi

    Forum Moderator

    I’m reluctant to change theme.

    Why? If it is the them causing the problem then you need to know one way or another so you can decide whether you want to use a new theme or put up with a less-than-functional blog.

    Tried the default theme, the buttons still don’t work.

    Also, for further info, if I edit an old post and click on the image to edit it, nothing happens either.

    I’m upgrading from 2.9.2 and having the sam eproblem.

    When I click to upload an image, rather than the usual pop-up window I am taken to a new page with no way to get back to my post and insertion of images does not work.

    esmi

    @esmi

    Forum Moderator

    Try:

    resetting the plugins folder by FTP or phpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress 2.9.2

    increasing the available memory.

    I traced my problem to the Headspace plugin. Deactivated it and all is fine now.

    Thanks – this fixed my problem as well. It was working fine till the 3.0 update. Still not happy with the menus in 3.0 though.

    Well I don’t use Headspace. I deactivated ALL my plugins and still I the upload buttons don’t work. Any other ideas? It’s really annoying me! Help!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Media uploader not working’ is closed to new replies.