WordPress.org

Support

Support » How-To and Troubleshooting » media uploader, “Missing a temporary folder” error

media uploader, “Missing a temporary folder” error

  • I’m using version 2.7.1

    When I try to use the upload/insert buttons:
    It opens the tool, I can pick files, but when it uploads I get a message that says “Missing a temporary folder”.

    I have tried all the suggestions I can find.

    Miscellaneous settings are:
    wp-content/uploads I have tried several variations here:

    uploads

    HGPauto/wp-content/uploads

    NO BEGINNING OR ENDING SLASH
    The blog address is
    …com/HGPauto for a format

    wp-content/uploads does exist and is writable (777)

    I’ve tried 3 different themes, that didn’t help either.

    I hope this is enough info, and the rite info.

    I am thinking this is a simple fix, that my hard head just doesn’t see.

    Thank you for any suggestions you could make.

Viewing 12 replies - 1 through 12 (of 12 total)
  • hmmm

    A little help please!

    I have now discovered that both of my blogs have a similar issue.

    The second is an 2.6 version, it gives a “Failed to write file to disk” error.

    I have been through Otto42’s sticky post on this subject several times.

    Installed the 2.7 version three times from fresh downloads, and tried all the suggestions(even the ones that don’t seem to relate).

    Thanks

    The “Failed to write file to disk” error is a permissions error. I’ve seen that one before. I’ve never seen the “Missing a temporary folder” error but it looks like a permissions error too. Have you seen this?

    Moderator kmessinger

    @kmessinger

    Missing a temporary folder and failed to write to disk are very different.

    For you first one, have you tried a full url, …com/HGPauto/wp-content/uploads? And have you just left it blank? Maybe your htaccess is preventing access?

    kmessinger,

    I plan to upgrade the 2.6 version blog, once I get the 2.7 working properly.

    Yes the full url is defined in the miscellaneous settings.

    I am not sure what to look for with htaccess, and I do not see an htaccess file in either wp installation folder. I do find htaccess in my root directory.

    Should each wp installation have it’s own htaccess? I did try adding htaccess to shut off mod_security (per Otto42’s sticky on this subject), it did not help.

    Thanks for your input.

    This is the full contents of the htaccess in my root directory. Could that be my problem?

    “# -FrontPage-

    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>

    ErrorDocument 404 http:rofitsite.com/main-24746

    Thanks again

    apljdi,

    No I hadn’t seen it, thank you.

    That is very useful, at this point tho I have about everything at 777.
    I will go through this and reset it .

    Thanks again.

    Moderator kmessinger

    @kmessinger

    Your htaccess looks ok (looks like many others) as far as I know. It should be in the blog’s root directory

    Under settings, miscellaneous, store uploads in this folder, put

    wp-content/uploads

    Under the next (Full URL . . .) leave empty. Make sure the “Organize my uploads into month- and year-based folders” box is checked.

    Thru ftp,cpanel or whatever you use, go to wp-content/uploads and create within the uploads folder a 2009 folder. Create within the 2009 folder an 03 folder. All folders from wp-content down should be 755.

    Go back to Posts and attempt to place an image

    kmessinger,

    It didn’t help, I’m getting the same error.

    The root directory for the blog did not contain an htaccess, so I put that one in from the sites main page. It doesn’t work with or without it.

    It’s starting to irritate me,LOL

    Thanks for your suggestions

    Moderator kmessinger

    @kmessinger

    You should now have a folder at http://www.site/blog/wp-content/uploads/2009/03. You should be able at least to ftp an image into the 03 folder. Try that.

    URL?

    Yes it works that way, but now the flash window for the add media won’t close lol. I can’t save the change.

    Maybe clean install #4 will be the jewel.

    I am going to clear database and delete install, and download a new zip.

    Thanks

    EricRihlmann

    @ericrihlmann

    Today I started experiencing this issue as well after successfully uploading several photos. I did an extensive search on this forum and Google I was amazed to not find a clear resolution. This lead me to searching through the WordPress core files for the error message to see what was going on. The error message seemed to be triggered after the file was uploaded to the temporary directory where php stores the newly uploaded file. I did not have access to this directory, so I contacted my host and they were able to repair/remove the temporary files in the directory. This immediately resolved the issue for me and I hope this helps resolve it for all of you.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘media uploader, “Missing a temporary folder” error’ is closed to new replies.