Support » Fixing WordPress » Media Uploader Issues

  • So my media uploader is no longer working properly at

    For both the single file and multi-file uploader, when i upload an image, it seems like the upload is successful. The thumbnail looks broken, but when you click the “Edit Image” button the image appears as it should. Also the file url adds a number at the end of the file name, as if a file of the same name had already been uploaded.

    The file is listed in the Media Library, but the thumbnail is still broken and when i go the the attachment link, no image, and the broken image place holder is not the correct proportions. (

    To attempt to correct the problem i have:

    – Disabled all plugins (no change even with all off)

    – Changed the plugin folder name logged in and changed the plugin folder name back

    – Changed the theme to twenty eleven

    – Changed the theme back (Base by GGP)

    – Manually re-installed 3.4.1

    – Repeat plugin and theme disable/enable

    – Manually installed 3.4

    – Repeat plugin and theme disable/enable

    – Auto-updated back to 3.4.1 (My patience was waning.)

    – Repeat plugin and theme disable/enable

    I have tested in Safari, Chrome and in Firefox. When i go to check that the upload is even in the wp-content folder with my FTP client, the file is not there.

    So i’ve hit a wall. What do i do? (And pretty please try and use advanced-beginner language. My apologies and thanks in advance!)

Viewing 11 replies - 1 through 11 (of 11 total)
  • Christine Rondeau


    Volunteer Forum Moderator

    it sounds like there’s some file permission issues happening. In the setting > media, maybe try unchecking the box – Organize my uploads into month- and year-based folders

    and see if that helps.

    If not, I would try to change the permissions on the uploads folder and/or contact the host and see if they have access to error logs and can pinpoint the reason for this.

    Have you consulted with your web host about:

    1. Your maximum storage allowance and/or:
    2. Your Max. # of files or # of files per folder?

    As the file is not finally appearing in the proper folder, I am assuming that your web host setup uses a temp file location for uploads, and when it attempts to write to your permanent folder, a server process fails for one of the reasons noted above. This may be logged in server error logs.

    Christine, i tried un-checking that setting and changed the folder permissions. No luck.

    Went to go check the error log and it full of this:

    [Sun Jul 15 18:31:31 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.

    Seacoast, thanks, but i have unlimited storage and there are currently only 20 files in the uploads folder. :/

    This is probably due to improper rewrite rules in your .htaccess file(s).

    Also, ensure the filename(s) has no spaces or special characters (, or $ or # for example) that are not allowed.

    I just regenerated my .htaccess file. No dice. That and all the files had no spaces or special characters to begin with.

    In attempt to go back in the error log when the problem started (the 10th, i thought it was a one off issue then) it looks like

    [Sun Jul 15 19:10:57 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
    [Sun Jul 15 19:10:57 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.

    Has been coming up continuously all afternoon. I pulled a few thousand lines of errors and it’s all the above and the occasional:

    [Sun Jul 15 19:28:11 2012] [error] [client] File does not exist: /usr/local/apache/htdocs/\xe3\x82\xb0\xe3\x83\x83\xe3\x83\x81-\xe3\x83\x90\xe3\x83\x83\xe3\x82\xb0-\xe3\x82\xb0\xe3\x83\x83\xe3\x83\x81-\xe3\x83\x88\xe3\x83\xbc\xe3\x83\x88\xe3\x83\x90\xe3\x83\x83\xe3\x82\xb0-c-1_2.html
    Use of uninitialized value $1 in concatenation (.) or string at /usr/local/cpanel/cgi-sys/fourohfour.cgi line 31.

    This is so freakin’ strange. The upload was working one minute and then not the next. I just assumed at the file issue was the file not the uploader.

    So am i hosed? :/

    I suggest contacting your host.

    Thanks for all the help. Much appreciated!

    Hi all!

    I have exatly the same problem as @elizabeth, i was searching for a solution and I tested all that I found on the forums but no luck… did you find a fix? I entered your site and y saw a post with image… can you tell me something?

    Thanks for all you help!

    Hi again,

    I just fix this bug! Look on settings->multimedia if the upload directory is correct, it must be wp-content/uploads. I had exactly your same behaviour uploading images @elizabeth and now it’s fine.

    Try and tell us, good luck.

    Hi Jessica – I am having the same exact problem. Did you ever resolve the issue? Thanks, Jack

    miguel: I wish that would have worked. The upload directory was correct in the settings. (That was one of the early things i checked.) I contacted my host and nothing was wrong on their end. Or so they said at least.

    So i finally just gave up, wiped everything and started over. Luckily the site is relatively new so the leg work isn’t so difficult. Everything is working ok now, but i’m running 3.4 not 3.4.1 and will not be updating anytime soon cause it sounds like there might be a bug in 3.4.1.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Media Uploader Issues’ is closed to new replies.