WordPress.org

Support

Support » How-To and Troubleshooting » Media Uploader Issue

Media Uploader Issue

  • I am having an issue with the media uploader. When I try to upload a video, it says that the max file size is 8MB.

    Now, I have gone into my php.ini and changed the upload_max_filesize to 300M

    upload_max_filesize = 300M

    And it never changes from 8MB, regardless if I use the Browser Uploader or the Flash Uploader. It stays the same, even if I clear the browser cache, or even log in from a different browser.

    Any ideas on how to fix this, other than uploading with a dedicated ftp program?

Viewing 11 replies - 1 through 11 (of 11 total)
  • well, does your host allow the upload size to be increased? Some do not….

    php_value upload_max_filesize 20M
    php_value post_max_size 20M
    php_value max_execution_time 200
    php_value max_input_time 200

    is some example code which may work, it can be used in the .htaccess file

    Vodoo … are those times in minutes or seconds?

    seconds. Definitely not minutes! lol

    *LOL* Just checkin’

    And, yes, I do believe that GoDaddy allows me to change max_upload_filesize via php.ini.

    I’ll try out your .htaccess solution and get back.

    godaddy definitely does allow php.ini

    rg_emulation = off
    allow_url_fopen = on
    memory_limit = 25000M
    post_max_size = 9000M
    file_uploads = On
    max_execution_time = 300000
    max_input_time = 300000
    upload_max_filesize = 9000M
    upload_tmp_dir = /home/content/r/v/o/rvoodoo/html/tmp
    server_admin = support@rvoodoo.com

    here’s a sample of mine. It’s called php5.ini however (my settings are way out of whack here, I put huge numbers here to troubleshoot something)

    also, to see if your changes are taking effect, use a phpinfo file

    <?php
    
    phpinfo ();
    
    ?>

    put that in a file at yur root, call it what you want, then visit it in a browser to see all your settings. Delete it once done

    Okay, I tried the .htaccess method and the server said it wasn’t configured properly and wouldn’t even let me log in.

    I stole some of your code and plopped into my php5.ini file, but it still won’t change the 8Mb upload size:

    register_globals = off
    
    expose_php = Off
    max_input_time = 960
    max_execution_time = 7200
    variables_order = "EGPCS"
    extension_dir = ./
    upload_tmp_dir = /tmp
    precision = 12
    SMTP = relay-hosting.secureserver.net
    url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="
    upload_max_filesize = 300M 
    
    rg_emulation = off
    allow_url_fopen = on
    memory_limit = 500M
    post_max_size = 400M
    file_uploads = On
    
    [Zend]
    zend_extension=/usr/local/zo/ZendExtensionManager.so
    zend_extension=/usr/local/zo/4_3/ZendOptimizer.so

    And I used the tip you gave me about how to check and see if the settings are being changed and it works; settings are begin changed.

    I can’t believe that, with all the CMS platforms there are out there that upload videos, that WP can’t get this part of it right.

    do you have the upload limit set in wp-config.php by any chance? It can be set there too.

    I know WordPress on godaddy can be configured to allow large uploads. Mine works fine……

    Just checked all of that and still no change …

    Chaz,
    If you’re running php5, make sure your php.ini file is named php5.ini.

    Here are my settings that i modified while on the phone with godaddy support:

    php_value upload_max_filesize 20M
    php_value post_max_size 20M
    php_value max_execution_time 200
    php_value max_input_time 200
    
    post_max_size = 64M
    file_upload = on
    upload_max_filesize = 64M

    jake – yes – I am running php5 and have the file names php5.ini

    Okay … this started working and I figured out why it wasn’t working before. The problem was that the particular WP install that was giving me issues was installed on a subdomain and I had put my php5.ini file there. Upon closer inspection, all I had was a regular php.ini file in my domain’s root directory.

    Ass soon as I deleted it and replaced wit with the file I had in the subdomain, it worked like a charm.

    Thanks guys!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Media Uploader Issue’ is closed to new replies.