WordPress.org

Support

Support » Plugins and Hacks » Portfolio Slideshow » [Resolved] media uploader doesn't show in custom posts

[Resolved] media uploader doesn't show in custom posts

  • Hi, I have a wordpress theme that has a portfolio section, in here I can add portfolio items just like a post, but the media uploader doesn’t show there. What can I do? is there a way to put it there?
    When I create a new post this is the url:
    “/wp-admin/post-new.php”
    And when I create a new portfolio item this is the url:
    “/wp-admin/post-new.php?post_type=portfolio”

    I could create the slide in a new post and then insert the shortcode inside a new portfolio item, but that’s not the idea.
    Can anyone help me?
    Thanks!

    http://wordpress.org/extend/plugins/portfolio-slideshow/

Viewing 2 replies - 1 through 2 (of 2 total)
  • If anyone cares I solved this adding a line of code in the metabox.php file:

    function ps_add_custom_box() {
    		add_meta_box('ps_custom_post_type_uploads', __('Portfolio Slideshow', 'port_slide'), 'ps_custom_post_type_uploads', 'post', 'normal', 'default');
    		add_meta_box('ps_custom_post_type_uploads', __('Portfolio Slideshow', 'port_slide'), 'ps_custom_post_type_uploads', 'page', 'normal', 'default');
    	}

    I added this:
    add_meta_box('ps_custom_post_type_uploads', __('Portfolio Slideshow', 'port_slide'), 'ps_custom_post_type_uploads', 'portfolio', 'normal', 'default');

    I put “portfolio” because is the name of the custom post type

    thank you for the post tonocarvacho.
    No further question now.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] media uploader doesn't show in custom posts’ is closed to new replies.
Skip to toolbar