Support » Fixing WordPress » MEDIA uploader Does Not Work – At All

  • I have 2 sites. One using 2.3.3 and it works great! Fast, reliable.

    I now have a new site just created using 2.5.1.
    I have 2 intel Mac’s running current OSX.
    Browsers using Safari, and Firefox.

    Media Uploader does not work on either machine. I click the upload button and I get a small blank box and according to Safari, it’s running an endless script. One moment I let the script run for about 30 minutes, until the item list reached 17,000.

    So, once the blank box appears, my browser is frozen and I have to ‘Force Quit’ to exit it.

    I tried the plug-in to cancel the Flash uploader but that didn’t work either.

    Any one have a remedy to this serious flaw?? And why hasn’t it been remedied in version 2.5.1, because I’m assuming it was there in v2.5.


Viewing 11 replies - 1 through 11 (of 11 total)
  • Also I should add, that the script code that seems to endlessly repeat, is this basically “”

    why it’s relaying this thousands of times, i can’t figure out.

    anyone have the same issue?


    Look at the sticky post at the top of the forum. There are some fixes there for that. At one point I could upload in IE but not FF. I updated and now I can upload in neither.

    I have tried all those suggestions with the exception of making a .htaccess file, because if i try to save a file with a period in the beginning of a file, my system won’t allow it, saying dots at the beginning of file names are reserved for the system.

    am i naming it wrong?

    i have no plug-ins activated.
    no flash plug-in did not work correctly for me.

    1. Make sure you uploaded all the WordPress files correctly. Really, this is probably the most common upgrade problem….

    Yes, uploaded exactly as noted. Deleted first and then uploaded.

    2. Clear your browser cache, restart your browser. Do it twice.

    Yes, did that as well.

    3. Update your Adobe Flash to the latest version (esp you Linux users!): Flash

    Yes, am running the latest Flash, I just downloaded last night.

    4. Another known issue is where the media buttons don’t appear at all. This happens when you have an older plugin interfering with the JavaScript.

    This sounds like my problem, but I have no plugins activated.

    6. mod_security might be causing problems. Disable it to see if that is the problem. To do this, make an .htaccess file in your wp-admin directory. Add this to it:

    Can someone tell me how to save this file because on a Mac, you’re not allowed to save a .htaccess.php file. Or am I doing something wrong?

    7. Try a smaller image, in pixels.

    I get a blank box, so I don’t even get this far.

    8. Q: It uploads without any errors,

    Again, not this far.

    9. Q: The gallery’s align left…

    Thank if anyone can help or suggest.

    Hi Butter Butter,

    I am having similar problems to yourself. Due to the flash uploading constantly failing I have installed the “no flash uploader” plugin. This has being working fine up until today when the whole shee-bang has frozen…just prior to plonking the image in my post. I have tried the .htaccess thing but to no avail. (BTW, they are two solutions down this route: is it before or after the existing code?)

    In short Butler Butler: to make an .htaccess file on a mac you must fire up your old terminal program (utilities folder i think) and type something like the following:

    ” defaults write AppleShowAllFiles Yes. “

    > enter > force quit finder > voila!

    That might not be 100% correct, you might have to find something similar.

    It will be nice when this image uploader glitch is ironed out.


    I am having this problem also after upgrading 4 different WP sites. The trouble seems to be only in Firefox when uploading an image from the “Write Post” page (post-new.php).

    However, if I login and upload an image using IE, it works. And then, it works in Firefox. But if I clear the IE cookies, it no longer works in Firefox.

    Here is my guess as to what is happing: The Macromedia Flash Player is using IE’s cookie store no matter if it is running in Firefox or IE. When using Firefox, Flash Player doesn’t have access to the admin_cookie in Firefox’s cookie store and thus does not send the cookie with the upload request.

    Searching the SWFUpload support forum, it appears this is a known issue:

    Demonstrated by:

    and another blog entry:

    My current line of thinking is to modify the WP core to rewrite the cookies as request parameters when GET’ing or POST’ing from the flash player, and then reading those request params back and re-setting the cookies. This would affect /wp-admin/async-upload.php and /wp-admin/includes/media.php.

    Would appreciate any feedback on that solution.

    butterbutter, I cannot create a .htaccess file on my Mac at work either. Macs seem to like filenames without extensions, but they have no love for extensions without filenames…

    I have to make a lot of .htaccess files on my Mac, and what I do is just make in my text editor, but I name it “1.htaccess”.

    Then when I am done with the file, I uploaded it to my Linux web server, where I then rename the file “.htaccess” in FireFTP.

    Another approach to creating .htaccess is use XTerm to get to a command prompt, cd to the directory where you need to create the .htaccess file, and then type “touch .htaccess”. Then the file is created. ls -la will list all files at the prompt, including hidden system files (files starting with a .)

    ! Hooray!
    Guys downgrade to Adobe Flash Player ver. 9.* !!
    It realy works

    To create a .htaccess on a Mac,.. you have to create the file first without the . then after you have uploaded it, rename it to include the . other OS X will see it as a restricted file and hide it from you.

    Anyone have a link for Flash ver. 9? Everything I’ve tried so far leads me to, or back to, ver 10.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘MEDIA uploader Does Not Work – At All’ is closed to new replies.