Support » Fixing WordPress » media uploader 3.4.1: wrong file permissions

  • Hi there

    Since my site has been updated to 3.4.1 I can’t load any pictures “full size” into my articles (broken link).
    Affected are only files, which had been added to library using wp 3.4.1.
    I am however still able to load all the reduced sizes of the same newly added pictures.

    What I discoverd so far is: When I upload a picture with WP 3.4.1, the full-size file in the media folder lacks reading permissions for IIS_IUSRS. All the thumbnails have correct permissions.

    After granting reading perms for IIS_IUSRS to the file in the library manually, everything works fine.

    Tried changing location of library, disabling plugins etc. etc.

    This seems to be a bug.

    Any help is greatly appreciated.


Viewing 8 replies - 1 through 8 (of 8 total)
  • Make sure that the setting to propogate directory NTFS permissions to all files in it is on for the /upload/ directory

    Good point, I checked that already.
    Only the uploaded file carries the wrong permissions, the downsampled files are ok. Inheritance of permission works perfectly when I create a file manually.

    I also just redid the automatic update on a different machine with the same result. stops working with 3.4.1.

    It is strange that the uploaded file does not have the correct permissions considering the file was created using the IIS anonymous user. Just to confirm, did you check the file owner and all?

    Also IIS is indeed running under the IUSR account ay?

    The owner of the uploaded file is IUSR, as well as the owner of the thumbnails.

    The Only Users of the uploaded files are Administators,IUSR and SYSTEM

    Files uploaded with wp 3.3.2 inherit everything correctly.

    I changed nothing about the server but installing wp 3.4.1

    I’m having the same problem – permission inheritance is set properly and the resized photos are fine, just the “full size” file that gets wacky permissions.

    I tried setting the upload_tmp_dir settining in php.ini to a specific path and ensuring the permissions were the same there. Another post indicated it may be inheriting the permissions of the folder it is initially uploaded to and then only “moved” to the uploads folder.

    This didn’t seem to help.

    Anyone find a solution?



    Forum Moderator

    @harley3k – I HOPE you’re not still using WP3.4.1 – which is the topic of this thread :).

    These forums work much better if you start your own thread – please see:

    Using 3.5.2.

    I guess I should start an entirely new thread for the same error because it’s a different version?



    Forum Moderator

    Yes, and it’s also likely that your issue is not actually identical.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘media uploader 3.4.1: wrong file permissions’ is closed to new replies.