Support » Alpha/Beta/RC » Media upload totally broken on my server

  • Resolved Richard Archambault


    Happiness Engineer

    So I decided to have a look at the bleeding edge and try out the media uploader. It’s completely broken on my shared hosting, but works beautifully on my local install. I tried it with a fresh install of the beta with no plugins and only Twenty-Twelve – fresh out of the box! Here is what’s broken:

    1) When I upload an image or several images using the new media uploader, I can see the progress of the upload(s), but when they are finished, I am sent right back to the “Select Files” screen of the Modal, rather than having a chance to edit the metadata of the image(s)

    2) I can see that the images are located in my upload folder, but when I tried to insert in the post, I had a 50/50 chance of the image being a “broken link” in the post editor

    3) If I go to the media library, I can see the thumbnails of all the images I uploaded; however, if I go to edit the image and it’s metadata, I do not see the image, and if I click “Edit Image” on the “Edit Media” page for that image, I get “Image data does not exist. Please re-upload the image.”

    So that’s a quick summary of my issue. The only difference I can see between my live site and my local dev is that local dev uses PHP 5.3.1 whereas live uses 5.2.17. Would that be the problem? Or could it be something else? What can I do to help track down what the issue is?


Viewing 7 replies - 1 through 7 (of 7 total)
  • Richard Archambault


    Happiness Engineer

    Ok, so now I’m using RC1; this time I can upload an image and I don’t get booted back to the Select Files screen, BUT I do get the following error:

    An error occurred in the upload. Please try again later.


    Again, this is on a Fresh WP install using 3.5RC1, using TwentyTwelve, no plugins.

    Another thing that’s changed: I can now see the full image in my Media Library, and not just the thumbnail. However, I still get the “Image data does not exist. Please re-upload the image” error if I click on “Edit Media”.

    Ah-ha, another new thing:

    I tried to add new media directly from the media library, rather than from the post editor. I got the following error there:

    Fatal error: Call to undefined method Imagick::setIteratorIndex() in /home/xxxxxxxx/public_html/ on line 92

    So it looks like it might all be related to something wrong with my host?

    Dominik Schilling (ocean90)


    WordPress Core Developer

    Could you tell us your ImageMagick version? Should be visible via a <?php phpinfo(); ?> call.

    Richard Archambault


    Happiness Engineer


    ImageMagick 6.2.8 10/20/10

    imagick module version 3.0.1

    Wow. That is an old version of ImageMagick and it makes sense that is brakes

    Richard Archambault


    Happiness Engineer

    Thank you! I shall point my host to here and request that they update it. 🙂

    I’ll mark as resolved for now, assuming that this is the issue.

    It is a issue that need to be solved in WordPress. See

    Most funny past is that if you runned ImageMagick 6.2.9 you didn’t had any problem ^^

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Media upload totally broken on my server’ is closed to new replies.