Support » Fixing WordPress » Media Upload Progress?

  • Anyone else noticing that when you’re uploading media that you no longer get a placeholder with a progress indicator? It is all happening in the background. This is terrible UI. Users now have no idea if the media they are uploading is actually uploading because it is all happening in the background. Why did the devs make this choice? Was it in error or on purpose? If on purpose, why?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator Marius L. J.

    (@clorith)

    Hi,

    We’ve not made any changes to this behavior, I just had a quick test and the progress indicators work as intended on my site.

    I would recommend following the troubleshooting steps outlined in our Master List, especially the part about disabling plugins and themes, to try and identify the root of your problems.

    Suddenly stopped working on my sites

    @clorith

    I’ve narrowed it down. If you are in the media section and drag n drop an image, that’s where you don’t get a progress bar anywhere. I get the progress bar whenever I upload media any other way. I’ve tested it on several different sites with the same results…sites using different plugins and themes, even one that is brand new.

    Same problem here, across numerous themes and servers. ‘Drop files to upload’ does not show a progress bar anymore. It has only become an issue since 4.9 on all of these sites.

    Moderator Marius L. J.

    (@clorith)

    Hi,

    Sorry for not following up sooner, are the problem you were experiencing still present in 4.9.1?

    Hi @clorith – yes, the same issue in in 4.9.1.

    Moderator Marius L. J.

    (@clorith)

    All right,

    Would you mind running our Health Check plugin and using it’s built in Troubleshoting Mode, then trying to make an upload?

    This will make your site appear as if it were brand new with no plugins or themes so that we can identify if it’s an issue you are having with some strange combination of scenarios or not.

    Hi,

    do you mean https://wordpress.org/plugins/health-check/ (the WP community plugin) rather than https://wordpress.org/plugins/my-wp-health-check/ by Frank Corso?

    I’ve used the first plugin, entered troubleshooting mode and performed several drop and drags into the Media Library. Unfortunately there is still no progress indicator. This is with (for example) Twenty Seventeen and no active plugins except Health Check.

    Moderator Marius L. J.

    (@clorith)

    Hi,

    Yes it’s the first one (sorry, I see my link got mangled in my reply there).

    If you are still not receiving any feedback then we’ll need to dig a little deeper, it is possible it’s being affected by some browser extension or other, could you try performing your uploads in an incognito session, or with another browser?

    Same in Firefox and Edge on Twenty Seventeen with no active plugins other than Health Check.

    I am having the same problem also. Seems to be working in the background, but no way of telling when you are done other than refreshing, and that will interrupt the process if you are not done. I wonder if a recent WooCommerce update is affecting it?

    Moderator Marius L. J.

    (@clorith)

    I’m going to ask that you create a new topic, we’ve had two releases since this, and issues are unlikely to be the same.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Media Upload Progress?’ is closed to new replies.