Support » Fixing WordPress » Media Upload Problems

  • Resolved Skazza

    (@skazza)


    Hi,
    after upgrading to WordPress 4.0, me and my other colleagues are running into few problems with the Media Uploader.
    When we try to upload a normal .jpg file as into 3.9.2, we receive an error and the media page is spammed with tons of “null images” of that uploaded image.

    Here’s the Media Page after trying to upload an image (with no positive results): http://i62.tinypic.com/2zzjfox.png
    And here’s the error (a normal error, italian localization): http://i61.tinypic.com/21edilf.png

    I hope you can help me to find the problem, i thought it was a plugin called “Regenerate Thumbnails” but I’ve disabled it and the problems persists. I’ve also deleted my old part of code that creates custom sized thumbnails but the error is still there.

    Thanks in advance!

Viewing 15 replies - 1 through 15 (of 39 total)
  • Same problem here…

    i am unable to use the media button on pages. I am also unable to change a page to password protected.

    But i am able to upload media to the library.

    As above. Just upgraded to WordPress 4.0 and my Add Media button seems not to be working. Again, I can add to the Media Library, but unable to place media in new posts.

    Same as above. Can’t insert media. Have no issue adding it to the library but nothing happens when editing a page and trying to insert media. HELP!!!! running twenty-twelve theme on WP4.0

    I was having similar problems today, new images throwing an unspecified HTTP error when uploading, not showing thumbnails in the Media Library, just grey placeholders (although previously existing thumbnails were fine), no image edit options in grid view.

    I was just advised on another forum to use the Force Regenerate Thumbnails plugin. I tried it on one test image, freshly uploaded and displaying all these problems, and not only did it get the thumbnail back, it’s fixed the upload and edit problems too, I’m now uploading without errors and able to edit as before. I hope this helps.

    I actually just went in and deactivated and/or deleted all unecessary plug-ins and I am OK with adding media to a page now. Can’t say for sure what plug-in was the problem.

    Force Regenerate Thumbnails helped me to remove the grey placeholder, but I can’t understand why tons of instances of the same image are created :\

    I am having the same problem with endless gray copies of each media file.

    Oh, that and all the menu buttons no longer work.

    I solved this gray copies problem.
    This problem was caused by a component of the WPML plugin called “WPML Media”, I’ve disabled this plugin and everything works fine.

    @skazza did you disable all of the WPML plugins or just the WPML Media plugin? We did the WPML Media Plugin and now it doesn’t upload at all.

    I just installed the latest versions of WPML Multilingual CMS and WPML Media on a vanilla WordPress 4.0.

    Both plugins work as expected. I can NOT confirm any Mediaupload issue with

    WPML-CMS 3.1.7.2 dated August 26th, 2014
    WPML-Media 2.1.6 dated August 20th, 2014

    Have you updated your installations to the latest versions as shown above?

    Since the “Add Media” button is not working (having just uploaded WP to version 4.0 I have had no choice but to revert my site back to version 3.9.1 where the button is once again working. During the next few days, I will check and load each available plug in, one at a time. Then perhaps in a week or two, will keep new back up files, and attempt to load WP 4.0 once again. Until then, if anyone has any comment, do let me know.

    I’ve solved the problem updating WPML to the latest version.
    Probably the problem of the missing “Add Media” is a plugin, just disable everything and activate one at time!

    I don’t have WPML installed and have deactivated or deleted every plug in that has to do with media. I can upload files to the media library, but then I am unable to view anything that has been (we assume) uploaded. I am also not able to add media to my posts.

    I am able to embed HTML elements in text edit without incident but that doesn’t help with photos.

    Same here. After installing 4.0, I can’t upload media. I get the http error and the grayed-out icons instead of my photos. I do not have WPML installed, and tried disabling all of my plugins. I still have the same problem. I’ve wasted a lot of time with this and still can’t upload anything.

Viewing 15 replies - 1 through 15 (of 39 total)
  • The topic ‘Media Upload Problems’ is closed to new replies.