Support » Installing WordPress » Media Upload Problem (The uploaded file could not be moved to error)

  • Resolved Tony Stark

    (@tony-stark)


    Hi,

    I have read several posts which seem to relate the issue I am having but on a brand new install (which is working as far as viewing and admin is concerned) I cannot upload files to the media library? This is on a VPS (Debian) box. I try to upload files and I get the following error:

    The uploaded file could not be moved to /var/www/vhosts/myblogdomain/httpdocs/wp-content

    None of the posts seem to have a concrete answer? Anyone know what is causing this and more importantly, what can be done to fix it?!

    Thanks

    Tony

Viewing 15 replies - 1 through 15 (of 41 total)
  • the 1st time try chmod 777 on /wp-content
    after that chmod 755 should work

    Hey Samboll,

    Apologies, I am a newbie on SSH (normally a Windoze man for my sins! but I am slowly converting ;-). I am using FileZilla to change permissions. I set the permissions on that folder (do I ensure it cascades?) to 777 and I can now upload but I cannot actually see the image in the admin or front-end.

    What I have noticed is that there is no “uploads” folder and even if I manually create one it just puts the media etc into the root of the site anyway. Do I even need it?

    What is so damn annoying as my dev install on WAMP works out of the box!

    Thanks for your help so far, I look forward to try and resolve this once and for all!

    Tony

    look in
    admin – settings – miscellaneous
    and see what folder you have there
    if necessary, create one under /wp-content and chmod it 777 also and should work

    Yep, it is the default but didn’t exist – created it and it can upload but the same problem as in the other post – I cannot actually see the images in the admin or front end when embedded in pages!?

    So the problem is only part fixed.

    correction! it is sorted now! 😉 WAHOO… thanks samboll, credit to the community.

    LOL – I make a change by checking the “Organize my uploads into month- and year-based folders” box and it breaks again!

    WTF!?!?

    I had this image upload problem.
    Your fix worked straightaway.
    However I read several solutions before it dawned on me exactly what I needed to do.
    This is it;
    1 Use your ftp client to open the folders on your website.
    2 Right click the wp-content folder and open “properties”.
    3 There you will see the chmod 775 setting. Change it to 777.
    4 Do the same to the “uploads” folder.

    I have a security question: Is it really safe to leave these directories in 777? I have seen a lot of WP advice sites that recommend never using 777. However, I can’t get media uploads to work any other way.

    Hoodedmonkey

    (@hoodedmonkey)

    Wow MakeitCount you are a legend!!!!!

    Thank you so much you are the only person I’ve found that posts information so it’s easy to follow.

    Cheers dude

    chuckiej

    (@chuckiej)

    If chmod 777 is the answer for every wordpress problem then wordpress is one big security hole. Stop telling people to do that!

    OK, I did have this same exact probleme and steps as above. I know many people got this trouble. After a couple tries, I gave up I found this post via Google. Thanks. But not working for me, so here is what I did and now it is working super fine !
    (seems like the installer of WP was missing stuff)

    – login to your ftp
    – make your wp-content folder 755
    – inside wp-content create a new folder called “uploads”, make it 777
    – inside the control admin panel, go to settings>miscellaneous and on the first line enter “wp-content/uploads” as where your uploads will go to.
    Save and go try to ad a new image in a post and it will work superb !

    I had the above suggestions working fine until today, after upgrading WP.
    Now I’m getting same error messages reported here. I noticed that the files I had before were uploaded to a folder 07 (created by WP for July) bearing my username as the owner. But the folder created today (by WP?) for August, show “Apache” as the owner. Does it make a difference?

    I’m noticing the same issue as what ‘vschafer’ has pointed out. I am not the user on the ‘2009’ folder within the uploads folder, ‘Apache’ i, i’m thinking this has something to do with why i can’t upload images!

    Yup, as soon as I let WP create the folders they are owned by ‘Apache” and I cannot upload to them, regardless of CHMOD settings.
    So I created the folder Uploads manually over FTP and chmodded to 0755. Of course then I can not set in Admin the archiving on a Year/Month basis because WP would create a new folder each Year/Month which I cannot upload to.
    So everything is in Uploads; a bit messy but there is the “Unattached” indication in Admin/media.

    Try turning off PHP Safe Mode. That solved it for me.

Viewing 15 replies - 1 through 15 (of 41 total)
  • The topic ‘Media Upload Problem (The uploaded file could not be moved to error)’ is closed to new replies.