Support » Fixing WordPress » Media Upload not working (http error)

  • I am aware that there are lots of issues and information out there on this problem, but many of them in the forums are 3+ years old. I wondered what the current suggestions are for when the Media upload gives an http error. I deleted extraneous plugins, had my host company (GoDaddy) check the apache file size limits, and tried deleting extra files that were unused. I have tried using the multi-item uploader as well as the browser uploader. I have not tried an ftp uploader though I am willing to if someone can recommend one for me to use on an old and tired Mac.

    I am using Jetpack, which I read could be a problem. But I am worried that if I deactivate Jetpack, once I reactivate it, the images may not work anyhow.

    I read somewhere else that I should be current on Flash updates – and I think I am, though I assume that’s only an issue with the multi-item uploader and shouldn’t affect the browser uploader.

    Anyone have any current suggestions?

    Thanks in advance!

    Website is at: http://www.mmdrdesigns.com

Viewing 15 replies - 31 through 45 (of 48 total)
  • themechanicdoctor

    (@themechanicdoctor)

    Same here;
    Had the problem happen a couple times before but just had to re-upload the image and it was working all good after 1 or 2 try but now all my images seem to get the HTTP error…

    I was trying to add 16 pictures earlier of different size from big to small, .jpg and .png and only 2 on 16 get uploaded and every time i try to re-upload them 1 or 2 more work. After maybe an hour of trying I have been able to upload 13 of the 16 pictures.

    It all started happening after v.4.6 but now I’m on 4.7…

    Is there a sure fix for this yet?

    YSMR

    (@ysmr)

    I have tried all recommendations on many different posts about this and the ONLY one that worked was updating to PHP 5.4 from 5.3 in my host (GoDaddy) Programming Language options on the main c-Panel page.

    upbeatguy

    (@upbeatguy)

    I tried loads of fixes listed on various websites, however the fix that worked for me was to add a line of code to the .htaccess file to modify the PHP version being used.

    The default our web hosting provider was using 5.5, but 5.6 and 7.0 can also be specified.

    Adding the following line of code to the .htaccess file cured the image upload issue for me on various sites.

    AddHandler application/x-httpd-php56 .php

    (Note the gap before .php should be left exactly as shown)

    For 7.0 it would be:
    AddHandler application/x-httpd-php70 .php

    Your web hosting provider should be able to advise you what versions of PHP they support.

    outwardjourney

    (@outwardjourney)

    I just started encountering this issue.

    When I deactivate JetPack 4.5 the images will upload properly. Otherwise they will through an error if JetPack plugin is enabled. This is definitely an issue around the JetPack plugin.

    Unfortunately, I haven’t been able to find the appropriate fix for it. 🙁 I am subscribing to this thread in hopes that someone comes up with one soon!

    saqlainabbas

    (@saqlainabbas)

    Hi Everyone

    i am facing issue to upload image from WP App (android) . when i upload any file from APP blank icon show in media library. ?

    this issue is only in When i upload media from APP.

    Please tell me how i can resolve this>>????

    So the way i fixed this was way more simple. For some reason the error message would just pop up, even though nothing I did was different. But to bypass it, instead of saving images in my picture folder, all I did was save them in my download folder. So when I tried to upload them, it worked. Maybe the file is different when it reads it but that was all i did. Hope it helps someone else.

    you not understand my question please read it again.

    i tried as your idea but this is not working.

    I’m having the same issue and none of the referenced fixes have worked. Have anyone found some sort of word around to get images uploaded? At this point I can’t load any, they all HTTP error out.

    Thanks asirota, I had the same issue and GD fixed it too. Much appreciated!

    @neozazmatt – have you tried switching to the GD library ?

    Use the code in this file

    https://github.com/getsource/default-to-gd

    And add it to your functions.php in your theme. Make sure you’re using a childtheme so an update to your underlying theme doesn’t wipe out this (or other) changes to the child theme edits.

    By the way @5wes13 – could you provide your server configuration. Load up both the Debug Bar and Debug Media plugins and post the server configuration and Media output please:

    https://en-ca.wordpress.org/plugins/debug-bar/

    https://en-ca.wordpress.org/plugins/debug-media/

    There is a bug on core trac which is difficult to fix and any situations where this problme is replicated and fixed with GD would be appreciated to record. Here’s the bug.

    What was the solution finally ? Thanks.

    Hello. I seem to have the same issue of a http error when I try to upload images. Deactivating all my plugins didn’t fix the problem nor did changing themes. What can I do?

    Thanks!

    Thank you upbeatguy (@upbeatguy) that worked for us!

Viewing 15 replies - 31 through 45 (of 48 total)
  • The topic ‘Media Upload not working (http error)’ is closed to new replies.