Support » Fixing WordPress » Media Upload not working (http error)

  • I am aware that there are lots of issues and information out there on this problem, but many of them in the forums are 3+ years old. I wondered what the current suggestions are for when the Media upload gives an http error. I deleted extraneous plugins, had my host company (GoDaddy) check the apache file size limits, and tried deleting extra files that were unused. I have tried using the multi-item uploader as well as the browser uploader. I have not tried an ftp uploader though I am willing to if someone can recommend one for me to use on an old and tired Mac.

    I am using Jetpack, which I read could be a problem. But I am worried that if I deactivate Jetpack, once I reactivate it, the images may not work anyhow.

    I read somewhere else that I should be current on Flash updates – and I think I am, though I assume that’s only an issue with the multi-item uploader and shouldn’t affect the browser uploader.

    Anyone have any current suggestions?

    Thanks in advance!

    Website is at: http://www.mmdrdesigns.com

Viewing 15 replies - 16 through 30 (of 48 total)
  • Same, since upgrading.. so annoying

    I also have the problem, on 4.6.1. Plus I cannot see the Media Library nor I can add a media to any article. Old media in old articles are displayed correctly.

    I think i’m in the same boat as you guys and i also think the entire problem was caused by jetpack’s photon module.

    Jetpack has been causing me a lot of trouble lately, i’ve talked to their support and they have confirmed i’m not the onl one and they’re working on it. unfortunately, though, i can’t wait anymore (it’s been a while already). it’s a shame really because the photon module is actually very very helpful.

    Now i’m stuck with this HTTP error everytime i upload media files and don’t know how to get rid of it… even now that jetpack has been deactivated and uninstalled!

    Hi,

    I have the same problem. I tried a clean install in English (and Spanish) on version 4.6.1, and the media library doesn’t work. I get this JavaScript error:

    Uncaught TypeError: Cannot read property 'limitExceeded' of undefined
    load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,underscore,shortcode,backbone,wp-util,wp-b…:343 Uncaught TypeError: Cannot read property 'hasClass' of undefined(anonymous function) @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,underscore,shortcode,backbone,wp-util,wp-b…:343dispatch @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:3r.handle @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:3trigger @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:3a.event.trigger @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:9(anonymous function) @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:3each @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:2each @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:2trigger @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:3(anonymous function) @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,underscore,shortcode,backbone,wp-util,wp-b…:342i @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:2fireWith @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:2y @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:4c @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:4XMLHttpRequest.send (async)send @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:4ajax @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:4j @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,underscore,shortcode,backbone,wp-util,wp-b…:342k @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,underscore,shortcode,backbone,wp-util,wp-b…:342m @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,underscore,shortcode,backbone,wp-util,wp-b…:342n @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,underscore,shortcode,backbone,wp-util,wp-b…:342(anonymous function) @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,underscore,shortcode,backbone,wp-util,wp-b…:342dispatch @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:3r.handle @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.6.1:3

    I there is a fix, please share it. Thanks!

    UPDATE:

    I deleted the browser cache entirely and all Internet files and now the Media Library seems to work just fine. Really weird as I did a clean, new install in a different domain. Apparently it works fine now, I hope this helps.

    hitechbiniou

    (@hitechbiniou)

    This is a real nuisance.

    I’ve been struggling for days reading all the wordpress thread and applying all the fix possible and still the HTTP error appear for files over few Kb.

    Why are we left alone an loosing that much time fixing a bug from a wp update.

    Running wp 4.6.1

    On that same server, one of my other site had the problem and I could fix it with the .htaccess codes added.

    SetEnv MAGICK_THREAD_LIMIT 1

    Please help but don’t ask me to supply a Bible full of information, codes and whatever.

    What would be nice is a working 4.6.2 WordPress update!

    regards

    arwarinseo

    (@arwarinseo)

    Hi

    same problem on 4.6.1 and still

    Kisa-chan

    (@kisa-chan)

    I’m having the same problem.
    I can upload some images but they are not visible unless using the whole path, and other images are just not saved.

    hitechbiniou

    (@hitechbiniou)

    I finallay got sorted out.
    I am using WordFence on the root domain of my server so ALL my addon domains where affected by the root .htaccess

    dsouzacorina1

    (@dsouzacorina1)

    Here’s how my image upload error got resolved:
    Had to change the path in wordpress where files get stored.
    In Settings- Media- Store uploads in this folder

    I began facing this error after I migrated my site to a different domain.

    chirilavictor

    (@chirilavictor)

    I have some blogs on a server and on two fresh wordpress 4.6 install I get this http error when I try to upload an image (any image)
    It’s not an server issue because on the other blog where I run older versions of wordpress everything is ok.
    On the last couple of days I’ve tried everything(modify .htacces, php.ini, functions.php, the image size, the image format, the browser ). This is the most annoying issue.
    The most strange thing that happens is that some images are uploading fine and other don’t. But this is complet random. After I refresh the upload page the image is there in a strange form.

    Look: http://idei3d.co.uk/product-category/pokemon/
    Here the images that are small are the ones that I received the Http error.

    Please tell me if anyone have a clue why this happen.

    I can confirm that various .htaccess and user.ini fixes does not fix the HTTP error upload we have. We did not try disabling Jetpack as we are using it in all sorts of places and it is not a solution.

    Our configuration is:
    WP 4.6.1 being used on GoDaddy Managed WordPress with php 5.4.45.

    We were still encountering this problem. Here is the sample JPEG which breaks WP which is only 2MB in size but 3600 px across as a test image.

    Here’s the smaller one that worked without any edits to the WP configuration.

    I tried to increase memory size in user.ini with no luck. I also tried the .htaccess directive:
    SetEnv MAGICK_THREAD_LIMIT 1

    That didn’t do anything either.

    For me, the only thing that actually worked without any configuration changes is reducing the size to 1800 px across (halving the resulting image).

    I can also confirm using the GD image library fixes the upload problem for even the larger image. I popped this code into functions.php and GD is used now, which is a bit slower at creating thumbnails but it does work.

    So there are a lot of combinations of issues on various hosts but for us on GD ManagedWordPress only using GD fixes the issue.

    Hey,
    I had an issue too and found out that my share host was running php version 5.5.36. I had to add ”AddHandler application/x-httpd-php56 .php” to the .htaccess file to get the server to run php 5.6

    I hope this helps

    Thanks @asirota for your reply.
    I used the GD image library from GitHub and it works now. And it is faster too.

    Thanks again! 😀

    Thank you SUNSEEKIN. I also use GoDaddy, updated to WP 4.7 and experienced uploading issues. Changed the PHP version as instructed, as well as blank out the upload path in the database… and I was immediately back in business. THANK YOU!

    Same issue here: I upload 5 images just fine, and on the 5th the “http error” appears out of nowhere after many years of running WP on several sites. Nothing changed in the minutes between image #4 that worked and image #5 that didn’t work, as far as I can tell.

Viewing 15 replies - 16 through 30 (of 48 total)
  • The topic ‘Media Upload not working (http error)’ is closed to new replies.