Support » Fixing WordPress » Media Upload not working (http error)

  • I am aware that there are lots of issues and information out there on this problem, but many of them in the forums are 3+ years old. I wondered what the current suggestions are for when the Media upload gives an http error. I deleted extraneous plugins, had my host company (GoDaddy) check the apache file size limits, and tried deleting extra files that were unused. I have tried using the multi-item uploader as well as the browser uploader. I have not tried an ftp uploader though I am willing to if someone can recommend one for me to use on an old and tired Mac.

    I am using Jetpack, which I read could be a problem. But I am worried that if I deactivate Jetpack, once I reactivate it, the images may not work anyhow.

    I read somewhere else that I should be current on Flash updates – and I think I am, though I assume that’s only an issue with the multi-item uploader and shouldn’t affect the browser uploader.

    Anyone have any current suggestions?

    Thanks in advance!

    Website is at: http://www.mmdrdesigns.com

Viewing 15 replies - 1 through 15 (of 48 total)
  • I was experiencing the “http error” on a few websites about six months ago. I found that the only way to get rid of it was to deactivate every plugin you have installed and then reactivate them one by one until you find which one(s) are causing the problem. It isn’t always a plugin conflict, but more times then not I found it was. It also doesn’t hurt to switch to a different theme to rule out that causing the problem. The Twenty Sixteen and Twenty Fifteen themes are very stable.

    If you are worried about Jetpack being deactivated causing your site to blow up then I would recommend that you take a full site backup before fiddling around.

    A quick solution to get around the “http error” is to use Add From Server.

    Thank you for your response! I did disable Jetpack and tried uploading with the same results. Either I get a visible http error or I just get a blank “?” as the icon for the image with no data attached. I also tried the “Add from Server” plugin and even if the file is on my hosting server and I upload it to the media library, it is still showing up with a blank file. Unless I am using it wrong. Here is what I did using “Add from Server”:

    I uploaded a file to my hosting server, navigated to it from “Add from Server” and then hit the Import button. It tells me the file is in my media library, but when I go to the library, it is still a “?” icon with no media details. If I re-import an image I have deleted from my library previously, it seems to be able to upload it properly, but not with new ones. So basically, no matter how I upload it seems to be having the same issue (though I still have not tried a true ftp upload…might try that next.)

    I feel like this is an issue with my actual hosting company but they have already assured me that it is not them.

    A bit of background information regarding this site which may be relevant to this issue since it’s only come up recently:

    I was working on this WP site on a separate domain (still within our web hosting domain) while it was under construction at new.mmdrdesigns.com. When I completed it, we swapped over the domains, so that the WP domain that I had been working on was now hosted at my main domain – http://www.mmdrdesigns.com and the new.mmdrdesigns.com domain was now unused.

    Could there be an issue somewhere that the images are somehow not being allowed to be stored on the main domain or maybe some navigation issue? I’m really not sure what I am trying to explain, but this is the first time I have tried to upload images since we swapped the domains a couple of weeks ago. And this is the only time I have had this error.

    I will continue to try deactivating my plug ins, but the ones I have left don’t seem to have any relation to media uploads.

    Thanks again!

    Well, I have to change this answer slightly. I deactivated all plugins and checked all of them. Nothing changed. I discovered another thread that said to find the .htaccess file in the WP root directory and add a line of code, but I couldn’t find the .htaccess file at all in the WP root directory. I could search for it and it told me where it was, but I can’t physically see a file with that name.

    I re-tried using “Add from server” after uploading my images to a different spot on my server and oddly, one image worked and the other 5 or 6 images still failed. The one image that worked was a cell phone image. My max file size is set to 100MB (as it tells me from the media upload screen). All files are much smaller than that. 6-10 MB, I think. The Cell one was 2MB. Is there something wrong with my file size settings that I can’t find? GoDaddy assured me that the file size requirements on their end were all set. I’m thinking of trying them again and hoping to get a different person to help.

    Is max file size based on all files or individual files?

    Any thoughts?

    Oh wait. I just noticed on my file manager that the larger ones that didn’t work are labeled as Type: text/x-generic even though they are .jpg images. How is that possible? The cell phone image is labeled as image/x-generic. Can something be wrong with my files? I can see them as images on my computer though and they are .jpg as the file extension.

    Hmmm…

    I was able to change how my file manger sees the files, but uploading them to the Media Library didn’t work still. They still have the http error. So now I will try some smaller images and test them out to see if it is size based.

    Wow, you have been busy.

    I discovered another thread that said to find the .htaccess file in the WP root directory and add a line of code, but I couldn’t find the .htaccess file at all in the WP root directory. I could search for it and it told me where it was, but I can’t physically see a file with that name.

    Are you using cpanel to view the files? .htaccess is hidden sometimes. Look for a checkbox that says “show hidden files” or something along those lines.

    Interesting that the one image uploaded and the rest didn’t. Did you take all of your images that you are trying to upload? Were they all taken on the same camera? Try downloading a random image (the WordPress logo maybe https://wordpress.org/about/logos/) and see if it uploads.

    As for the file upload limit, I don’t think that is the problem. Usually you will get a different warning if the file that you are trying to upload is too big. What is your current max upload size?

    Thanks! I found the hidden files checkbox and finally found the file – but the added line of code also did not fix the problem. I still got an http error. The code that the other thread referred to was to add this: ‘SetEnv MAGICK_THREAD_LIMIT 1’ at the top of the file. I will be removing it shortly, just in case it changed something else.

    I did take all of the images myself. The larger images were from my Nikon camera, while the one image that was smaller and did work was from my cell phone.

    I also did just try to upload some more basic images – things that were not photographs, but just graphics – and those didn’t work (one of which was a simple 12KB jpg). I did however notice a difference between upload issues.

    1. I get the http error and the file upload stops at 100% and never really completes (doesn’t show a thumbnail or icon), seemingly on larger files.
    2. I get a completed file upload which shows the “?” icon and offers me the ability to Edit the upload – assuming anything uploaded, which it didn’t. This seems to happen on the smaller files.

    I am so confused as to why it used to work fine on our old domain and then all of a sudden, once we changed domains, it does not work anymore. I might try on another computer just to eliminate my computer as the issue.

    Thanks again!

    Oh, but I did find 3 .htaccess files when I had searched. I only added that line of code to the file within /public_html/wp-includes.

    I also found the same file name in /public_html and in /public_html/wp-content/plugins/akismet.

    I’m not sure what the code actually does, so I’m not sure which one I should actually be adding it to.

    The wp-includes file has the following code – without the code that I added to the top:
    ‘<Files *.php>
    deny from all
    </Files>
    <Files wp-tinymce.php>
    allow from all
    </Files>
    <Files ms-files.php>
    allow from all
    </Files>’

    The public_html file has the following code:
    ‘# BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress’

    The file within the Akismet plugin folder has the following code:
    ‘# Only allow direct access to specific Web-available files.

    # Apache 2.2
    <IfModule !mod_authz_core.c>
    Order Deny,Allow
    Deny from all
    </IfModule>

    # Apache 2.4
    <IfModule mod_authz_core.c>
    Require all denied
    </IfModule>

    # Akismet CSS and JS
    <FilesMatch “^(form\.js|akismet\.js|akismet\.css)$”>
    <IfModule !mod_authz_core.c>
    Allow from all
    </IfModule>

    <IfModule mod_authz_core.c>
    Require all granted
    </IfModule>
    </FilesMatch>

    # Akismet images
    <FilesMatch “^logo-full-2x\.png$”>
    <IfModule !mod_authz_core.c>
    Allow from all
    </IfModule>

    <IfModule mod_authz_core.c>
    Require all granted
    </IfModule>
    </FilesMatch>’

    So, maybe I should be adding it to the Aksimet one? Though when I dialed Akismet it didn’t seem to fix the problem. I will be retrying that just to rule it out.

    I forgot to mention that when the upload fails in my #2 version above, as it is finishing it says “crunching” then finishes then gives me the “?” icon. Not sure I ever noticed that before.

    I also tried on another computer and it has the same issues. Nothing will upload. So obviously it is settings within WP/plugins or my host company.

    And above when I said “Though when I dialed Akismet” it should been “Though when I disabled Akismet”

    I also re-disabled Akismet and I still have the problem.

    I am truly stumped…and kind of new to WP, so I don’t even have new tricks to try.

    First, stop adding any kind of code. The error comes from Jetpack and the Photon mod, https://jetpack.com/support/photon/

    That is why the missing links have https://i2.wp.com/ as part of the path. If you moved from WordPress.com or used the photon mod then you have to tell your site where the real image is now stored.

    Go to a missing image in a post, page, wherever from the dashboard and edit. Try replacing the missing image with the real thing that should be in wp-content/uploads

    Unless you added a security plugin or one that modifies the htaccess file, all that should be there is

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress'

    Check the top paragraph here,
    Home

    It was of great benefit düğün fotoğrafçısı http://alinfotograf.com/
    thank you

    [redacted]

    Please do not post questions on others’ threads. If you have a question, start a new thread. thanks.

    For WP 4.6, image uploads to the media library all failed with an “Http error.” on the wordpress sites on my godaddy.com linux hosting account.

    The godaddy.com support tech made 2 changes:
    1. Upgrade the php version in cpanel to v5.6 from the default of 5.4.
    -use the “Select PHP Version” function in cPanel.

    2. Blank out the database “Upload Path” in wp_options
    -Use phpMyAdmin from cPanel
    -Select the database shown in wp_config.php
    -Click the table: wp_options
    -Search field “option_name” LIKE %path%
    -For the rows “upload_path” and “upload_url_path” :
    -Click Edit
    -Blank out the “option_value” field (large text box.)
    -Click “Go” (lower right corner of editor; you may need to scroll down to see the button.)

    I have the same problem with WP 4.6.

    @sunseekin, thanks for you hints, but it didn’t work out for me, as there were no changes after setting PHP to v5.6 and the values of the two fields you mentioned were already empty.

    Anyone has any other suggestions?

    Hello,

    I am having the same issues. Since upgrading to 4.6.1
    I have tried every workaround mentioned. Plugins, permissions, everything in this thread and all other discussions.
    Using ver 4.6.1

    Is there any real fix?

    Regards Glenn

Viewing 15 replies - 1 through 15 (of 48 total)
  • The topic ‘Media Upload not working (http error)’ is closed to new replies.