Ready to get started?Download WordPress


[resolved] media upload not working (5 posts)

  1. mrhiggs
    Posted 2 years ago #


    I have a brand new installation with default Theme and no Plugins activated. My problem is that trying to upload images under Media -> Add New does not work. I don't get any error messages, not even an HTTP 500 error, the request simply does not finish.

    I have read a lot of posts in this forum and tried all of the suggested solutions. Here is what I tried:

    - Disable all plugins (not necessary in my case since it's a new installation anyway)
    - Switch to Twenty Eleven theme
    - Upload folder under Settings -> Media is empty and should thus default to wp-content/uploads (I've also tried explicitly setting it to that directory without success)
    - Set permissions of wp-content and wp-content/uploads to 777 and change owner to the user PHP is executed with (in my case www-data). However, I do not think that it is a permissions-related problem, because a simple script I created in the wp root directory that executes mkdir('wp-content/uploads'); succeeds and creates the folder.

    I have decent experience in PHP programming, but this is the first time I work with WordPress, so I have no idea what could cause the problem. If you need any more information on my setup, please let me know. Any help is highly appreciated.
    Thank you!

  2. makeupchica
    Posted 2 years ago #

    I am having the same problem.

  3. esmi
    Forum Moderator
    Posted 2 years ago #

    @makeupchica: Please post your own topic.

    @mrhiggs: Have you tried checking your server's error logs?

  4. mrhiggs
    Posted 2 years ago #

    Thanks for the hint, esmi. The apache error log contained this line:

    /usr/sbin/apache2: symbol lookup error: /usr/lib/php5/20100525+lfs/suhosin.so: undefined symbol: php_mb_encoding_translation

    which I think was caused by a mistake I made when updating to php 5.4.
    I uninstalled suhosin and uploading works now (although I did have to change wp-contents/uploads permissions to 777).

    Thank you!

  5. esmi
    Forum Moderator
    Posted 2 years ago #

    Glad to hear that you're back up & running. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic