Support » Fixing WordPress » Media-Upload in plugins broken after WordPress 3.8 update

  • I’m developing a number of websites and have found that trying to add an image in plugin option pages that use the jQuery media-upload are not working and are styled incorrectly.

    1. The first thing I noticed is on the “Media Library” tab the search feature is behind the list of media and not at the top where it should be. I have a feeling this is a CSS issue that was missed with the change.

    2. The second problem I’m having is when I’m developing on a new account that has the tilde (~) in the URL. I am unable to upload media. The “Insert Into Post” fails to do so. An image placeholder shows and the image URL for the placeholder is http://mydomain.com/~myaccount/wp-admin/undefined

    These are the steps I have done to test/confirm this:
    1. I disabled all plugins and changed to a default theme.
    2. I tested the media upload in a page/post and it worked fine.
    3. I enabled a single plugin that had an option for media upload and the errors exist.
    4. I checked another site I have that is using 3.8 but without the tilde and problem 1 exists but problem 2 doesn’t.
    5. I checked another site I’m developing that is still on 3.7.1 and there is no problem.
    6. I enabled a different plugin that had and option for upload and the same errors exist.
    7. I tried this in Chrome, FireFox and IE.

    Can someone please check and confirm that these problems exist for them as well and any suggestions how to fix this?

Viewing 9 replies - 1 through 9 (of 9 total)
  • After doing some more research on this, I’ve found the following.

    Issue 1(one) above about the search in the media upload is a real problem. Every website I have with WordPress 3.8 has this issue. I think it revolves around the CSS styling of buttons and input fields. It’s making them to large so they go to the next line and are behind the list of media.

    Issue 2 was specific to something in the options table on my sites. I installed a fresh copy and this wasn’t an issue. I’ll try to find out what caused the problem but this part is resolved for me.

    you have to be rollback your wordpress version and just update those files which is required. auto update is the reason to take many problems in the wordpress.

    That is completely incorrect. The database was changed in WordPress 3.8, so you would also need to restore an appropriate database backup. You should also be aware that your site will running a very real risk of being hacked unless you keep WordPress up-to-date.

    @nostrodev: Please stop trying to encourage people to rollback to older potentially insecure, versions of WordPress. Not only is this “suggestion” positively dangerous and inappropriate in the vast majority of cases but you’re not even telling people how to do it properly.

    If you doubt my WordPress knowledge, check my profile.

    Thank you. This worked for me.

    Solution is not working, all the buttons in the WYSIWYG are editor gone when you implement that fix

    @paul-p: If you require assistance then, as per the Forum Welcome, please post your own topic.

    I had similar prolem after updating to 3.8.
    I could not delete any media, I could add, but could not delete.
    Tried to add in wp-config.php
    define('WP_DEBUG', true);
    and what did I get.
    DELETE FROM wp_options WHERE option_name = 'rewrite_rules'
    Just added access for current database user to use DELETE sql command.
    Solved my problem.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Media-Upload in plugins broken after WordPress 3.8 update’ is closed to new replies.