WordPress.org

Forums

Media Upload Error-Unable to create directory wp-content/uploads/2013/10. Is its (6 posts)

  1. jonescb2
    Member
    Posted 1 year ago #

    I've tried uploading several different file types to my media library and keep getting the same error.
    "Unable to create directory wp-content/uploads/2013/10. Is its parent directory writable by the server?"

    I had read other posts about this error and saw that the suggestion was to change the Uploads Settings to" default", however when I go to my Media Settings I can't even find an option or drop down menu to change this.

    Where exactly do I find this? Or any other suggestion on how to fix this error? Please help, time sensitive!!!

    thank you

  2. ClaytonJames
    Member
    Posted 1 year ago #

    when I go to my Media Settings I can't even find an option or drop down menu to change this.

    It's usually just a settings option found here: http://codex.wordpress.org/File:options-media.png

    Try temporarily changing the /wp-content directory permissions to 775 or 777 and see if WordPress can create the directories it needs and complete the upload. Be sure to put the permissions back where they were afterwards.

  3. boopie
    Member
    Posted 1 year ago #

    jonescb2 - did you find a solution to this? I'm having the same problem and changing the permissions isn't working. Just moved my staging site to live and am unable to upload media and new plugins. :/

  4. mdroamer
    Member
    Posted 1 year ago #

    Everything was working great on my site until 2 am...I've spent the last 20 hours trying to figure this out and finally under settings for media, I noticed there was a / in front of the default upload folder. I got rid of the / and everything is working now.

    Sorry I can't be more technical than that, but I hope it works for all of you, too.

  5. unthinkme
    Member
    Posted 1 year ago #

    I have had the same issue since upgrading to the latest version. I think is a glitch of your pre-installed theme and wordpress trying to keep your data but has a glitch along the way.

    All you have to do is change the media settings back to is default but is not an option button, instead you might see something like this:
    Settings>Media> /home/content/52/10232136/html/wp-content/uploads

    if you don't see that then go to the top where your refresh icon is and reinstall the wordpress version, the if the glitch occurs then the media settings should reappear- sometimes a change in the php or something else you do might get rid of this setting option.

    once it reappears- copy the default path right under the current glitchy one. - sorry for not having screenshots & good luck.

  6. ivorjohn
    Member
    Posted 11 months ago #

    Thank you mdroamer, you're a champ! Getting rid of that pesky slash made all the difference. Wish I had seen this before spending hours fiddling with permissions, dealing with hosting co, and re-installing a backup.

Topic Closed

This topic has been closed to new replies.

About this Topic