Support » Fixing WordPress » Media upload error since version 4.0

  • I have the same issue as many others since updating to version 4.0 and am unable to upload any media, if it does it shows as a grey box back can be reached via the edit media button.

    I have also tried the following steps to fix this issue:

    1) Updating all plugins
    2) Deactivating all plugins
    3) Switching to Twenty14 theme
    4) I am not using the WPML plug in which seems to be the cause for many.
    5) contacted theme devs
    6) contacted hosting company
    7)banged my head against a brick wall in the hope this is just a bad dream!!!

    Can somebody from WordPress please give a fix for this media error!?

Viewing 15 replies - 1 through 15 (of 40 total)
  • I am having exactly the same problem since the update. I am NOT using the WPML plugin either. I tried deactivating every possible plugin, and still no fix. My blog has been unusable since this update and I’m very frustrated.

    I have found uploading larger files is the problem, small images are fine but anything above a certain size, then boom media upload error.

    Hosting company have checked for errors and cant find any regarding media uploads.

    Have also made changes to the file size upload via php.ini and still no luck, this is definitely a wordpress 4.0 issue, that needs fixing asap, but so far this issue is falling on deaf ears

    Thanks Jersey peeps. It obviously is an issue with 4.0, but they seem to be ignoring us, or insisting it’s a plugin conflict (I deactivated everything, cleared my caches… no change). My images aren’t even that large. But I’ll see if tiny images might work. SIGH.

    I’m very tempted to ditch wordpress and head back to social engine ( i run a social website ) and having users complain and leave because of this issue is not helping at all

    Hello! Could you please check your hosting error log and paste them here please?

    [13-Sep-2014 13:23:49 UTC] PHP Warning: Illegal string offset ‘height’ in /home/jerseyp3/public_html/wp-content/themes/buddyboss/image.php on line 31
    [13-Sep-2014 13:24:20 UTC] PHP Warning: Illegal string offset ‘width’ in /home/jerseyp3/public_html/wp-content/themes/buddyboss/image.php on line 30
    [13-Sep-2014 13:24:20 UTC] PHP Warning: Illegal string offset ‘height’ in /home/jerseyp3/public_html/wp-content/themes/buddyboss/image.php on line 31
    [13-Sep-2014 13:28:20 UTC] PHP Warning: Illegal string offset ‘width’ in /home/jerseyp3/public_html/wp-content/themes/buddyboss/image.php on line 30
    [13-Sep-2014 13:28:20 UTC] PHP Warning: Illegal string offset ‘height’ in /home/jerseyp3/public_html/wp-content/themes/buddyboss/image.php on line 31
    [13-Sep-2014 13:31:36 UTC] PHP Warning: Illegal string offset ‘width’ in /home/jerseyp3/public_html/wp-content/themes/buddyboss/image.php on line 30
    [13-Sep-2014 13:31:36 UTC] PHP Warning: Illegal string offset ‘height’ in /home/jerseyp3/public_html/wp-content/themes/buddyboss/image.php on line 31
    [13-Sep-2014 20:09:08 UTC] WordPress database error Lost connection to MySQL server during query for query SELECT post_id, blog_id FROM wp_em_locations WHERE location_id=40 made by require(‘wp-blog-header.php’), require_once(‘wp-includes/template-loader.php’), include(‘/themes/buddyboss/single.php’), get_footer, locate_template, load_template, require_once(‘/themes/buddyboss/footer.php’), dynamic_sidebar, call_user_func_array, WP_Widget->display_callback, EM_Widget_Calendar->widget, EM_Calendar::output, EM_Calendar::get, EM_Event->output, EM_Event->get_location, em_get_location, EM_Location->__construct, W3_Db->query, W3_DbCache->query, W3_DbCallUnderlying->query, W3_Db->query, W3_DbProcessor->query, W3_Db->default_query
    [13-Sep-2014 20:09:08 UTC] WordPress database error Lost connection to MySQL server during query for query UPDATE wp_options SET option_value = ‘0’ WHERE option_name = ‘wordpress-https_ssl_host_diff’ made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), include_once(‘/plugins/wordpress-https/wordpress-https.php’), WordPressHTTPS->init, WordPressHTTPS->getHttpsUrl, Mvied_Plugin->setSetting, update_option, W3_Db->update, W3_DbCache->update, W3_DbCallUnderlying->update, W3_Db->update, W3_DbProcessor->update, W3_Db->default_update, W3_Db->query, W3_DbProcessor->query, W3_Db->default_query
    [13-Sep-2014 22:25:26 UTC] PHP Warning: Missing argument 1 for awpcp_clean_up_non_verified_ads() in /home/jerseyp3/public_html/wp-content/plugins/another-wordpress-classifieds-plugin/cron.php on line 226
    [13-Sep-2014 23:18:18 UTC] PHP Warning: Illegal string offset ‘width’ in /home/jerseyp3/public_html/wp-content/themes/buddyboss/image.php on line 30
    [13-Sep-2014 23:18:18 UTC] PHP Warning: Illegal string offset ‘height’ in /home/jerseyp3/public_html/wp-content/themes/buddyboss/image.php on line 31

    Moderator Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Your errors would suggest an issue with your theme, and your theme’s support forums are here: http://www.buddyboss.com/support-forums/

    Andrew it is not a theme issue, i can change to any theme and still get the same issues.

    I have contacted the theme dev and am fully aware of where their support forums are thank you very much.

    Moderator Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Which error messages do you get with the Twenty Fourteen theme?

    /HOME/JERSEYP3/PUBLIC_HTML/BETA/WP-CONTENT/THEMES/TWENTYFOURTEEN/IMAGE.PHP ON LINE 31
    ×
    WARNING: ILLEGAL STRING OFFSET ‘HEIGHT’ IN /HOME/JERSEYP3/PUBLIC_HTML/BETA/WP-CONTENT/THEMES/TWENTYFOURTEEN/IMAGE.PHP ON LINE 31

    Same problem.
    Waiting for WP fix!

    Think we will be waiting a very long time!! Have tried everything my end and still no luck, are you having issues with larger files?

    I tried the suggestion to upload only tiny images. This has been the only thing that has worked. Wonderful! I have a blog dedicated to art and now can only upload tiny, fuzzy low-quality images! I wasn’t exactly uploading mega-files before–everything was optimized and appropriate for the web. This is absolutely ridiculous! What do I have to do? Go back to Blogger so I can use my blog? I also did a bulk update of all of my plug-ins, just in case. But that did nothing either.

    Tom

    (@tom-hickey)

    Here’s some more data points: (Much more testing required.)

    Smaller images seemed to upload OK; larger ones failed (never reached “crunching”; received “html error” and upload failure).

    Turning off (unchecking) this setting in Settings > Media reliably corrects the problem when using 2012 theme and no plugins:
    “Crop thumbnail to exact dimensions (normally thumbnails are proportional)”.

    This does not work with 2014 theme.
    This works with Genesis Framework and Sample theme
    This does not work with Genesis and Focus theme.

    Tom

    (@tom-hickey)

    Some progress <?> or at least more data points towards finding a fix:

    In theme 2014, commenting out these two lines allows larger file uploads to work:

    // Enable support for Post Thumbnails, and declare two sizes.
    add_theme_support( 'post-thumbnails' );
    //set_post_thumbnail_size( 672, 372, true );
    //add_image_size( 'twentyfourteen-full-width', 1038, 576, true );

    In Genesis themes, using add_image_size causes uploads to fail. Removing this from the child theme allows the uploads to work.

    Turning on “Crop thumbnail to exact dimensions (normally thumbnails are proportional)” consistently causes media uploads to fail.

Viewing 15 replies - 1 through 15 (of 40 total)
  • The topic ‘Media upload error since version 4.0’ is closed to new replies.