Support » Fixing WordPress » Media Upload Error on WP 3.5.1

  • hi people,

    i’m having a “http error” everytime i try to upload a image.
    i dont know why is this happening, because it was working perfectly last week and then stopped. since then i upgraded my wp version, so it might be related with this, but im not sure. my wp version is now 3.5.1. (upgraded from 3.5)

    i can upload small images (up to 100kb and/or up to 1000px wide), but sometimes images bigger than that just dont work. (i was able to upload a small (640×480) bmp image with about 1MB, but not a wide (3600×2800) jpg with only 600kb, which makes no sense at all).
    when crashing the loading bar stops about 70%, sometimes more, the image gets uploaded only in full size (thumbs not generated) and the media editor cant find the image. It says that the requested media dont exist. still the file can be deleted from the media library.

    i’ve been searching web for solutions and found almost nothing.
    here is what i’ve already tried:
    – uploads with diferent file sizes, formats and dimensions to check if it’s compatibility-related – couldnt find a pattern to explain the error;
    – edited .htaccess file to include
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    as it worked with some people, but not with me;
    – checked upload and file size limits in php.ini (everything is fine there)
    – disabled all plugins (problem persists);
    – changed theme (twenty twelve has the same problem as well);
    – reinstall wp 3.5.1 (nothing changed);

    i’ve seen a lot of people with the same problem but just a few of them could get a proper solution. some solutions was related to plugins issues, or themes, or php config, but nothing i’ve tried worked. any ideas?


Viewing 7 replies - 1 through 7 (of 7 total)
  • It looks like you’ve checked all the normal reasons for upload problems. Have you tried using the “Browser Uploader”, as opposed to the default Flash uploader? Could be a Flash issue.

    Other ideas – perhaps during your update to WP 3.5.1, the download was interrupted and the uploader was slightly corrupted, or perhaps this is an issue with a particular browser.

    thx for replying, @odai

    oh, yes…
    i forgot to mention, i’ve tried the browser upload as well, but it’s also causing upload error. (is it flash based? didnt knew it)
    i tested other browsers (chrome, ff and ie, last versions of them) in win7 and vista.
    all folders has permissions since smaller files can be recorded.

    the only thing i havent tried yet is to roll back wp installation.
    it would cause the plugins to lose their configs, isnt it?

    what kills me is the vague “http error”… which could be more specific.

    The browser uploader isn’t Flash-based, so we know that Flash isn’t the issue here.

    Re-reading your post, it sounds more like an issue with the way files are being written to the database, not that they’re not uploading.

    I had that problem on a site once, where files were being incorrectly stored and WP couldn’t find them later. I don’t know what caused it, but I fixed it by re-installing WordPress.

    But I see in your original post that you already tried that and it didn’t work :/

    Could you give us a link to your website, so we can examine it (if that’s not too personal)?

    I my case i also got HTTP Errors. Turns out that the strict security settings at the provider were the culprit (Westhost).
    You can ask them to add exceptions to ModSecurity for all the pages that deal with uploads, in my case:

    Exceptions pages:


    Als the ajax admin page in WP is important to except.

    I have had this and tested for days with 3.4 vs 3.5 and several different hosts, and have concluded that 3.5 uploading uses tons of processes on your server. In most cases your hosts server will have a number of process limit, in my case 25. Using 3.5 and after uploading 2 images, my server processes were maxed out, and it was giving ‘http eror’ and breaking my site and slowing down my server. I tried the same thing on a different host company and it worked fine. So some hosts dont like the way they built the 3.5 uploading?

    this is still an issue as far as I’m concerned – i’m running a test install on localhost – images are uploaded to wp-content – but no thumbnails appear (or appear to be created – are these created as images or do they live as blobs in the database)?

    This thread is not your issue – if you need help, you need to start a new thread –

    from the forum welcome
    “Unless you are using the same version of WordPress on the same physical server hosted by the same hosts with the same plugins, theme & configurations as the original poster, do not post in someone else’s thread. Start your own topic. ”

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Media Upload Error on WP 3.5.1’ is closed to new replies.