WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Media upload click not working – media-uploader.js bug

[Resolved] Media upload click not working – media-uploader.js bug

Viewing 6 replies - 1 through 6 (of 6 total)
  • @mohan
    Thanks for pointing that out. I know very little js but finally got it to work.

    selector.find('.upload-button').on('click', function() {
       optionsframework_add_file(event, $(this).parents('.section'));
    });
    selector.find('.upload-button').click( function( event ) {
       optionsframework_add_file(event, $(this).parents('.section'));
    });
    Plugin Author Devin Price

    @downstairsdev

    Hi. This was a bug in the previous version when a file was uploaded, then removed, and then the user attempted to upload again. But should have been corrected in the 1.6 release. I just tried again in Chrome and haven’t been able to reproduce the issue.

    @ronangelo You are correct- the event var needs to be passed (I’ll make the update), but it looks like this is only in the rebind after an image has been removed. Is that where you were experiencing the issue?

    I’m still facing this problem. The media uploader does not work. I’m on WP 3.7.1. I tried the above fix but it still does not work.

    Please provide a proper fix.

    This is what it says in FF console :

    Warning: Use of getPreventDefault() is deprecated. Use defaultPrevented instead.

    Plugin Author Devin Price

    @downstairsdev

    Hi @varundave. Would you mind testing with the latest on GitHub? I’m planning to release this on Monday: https://github.com/devinsays/options-framework-plugin

    There have been some changes to the media library code that may resolve this.

    Hi @devin

    I just did an update you recently released. I’m still facing the problem because, i have modified the code to change the menu position from under “Appearance” to a “top level menu.”

    After the update, the uploader was working but, as soon as i modified the code to get the menu to a top level position, it stopped working again.

    I think, the enque script code is not letting scripts to load if the hook and slug are different.

    Can you please provide a proper way to change the menu position without breaking the functionality ?

    Thank you for your time.

    –Dave

    Plugin Author Devin Price

    @downstairsdev

    Hi Dave. Moving the menu location was never explictly supported in the plugin- however, I do plan to add support in the next major version: http://wptheming.com/2013/11/options-framework-roadmap/

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Media upload click not working – media-uploader.js bug’ is closed to new replies.