Support » Fixing WordPress » Media upload button is not working.

  • digimarkup


    I’m having this problem with all of my websites except for one that has a SSL certificate. This problem is only happening in Chrome. I disabled all plugins and activated the 2017 theme and the problem still exist.

    Whenever I try to upload an image in the post editor and click the select files button, nothing happens. The funny thing is that I can only upload images when I go to Media>Add New>Select Files. In chrome I right clicked the Select Files button and clicked inspect element and copied the html for both buttons.

    Button for the blog post Featured Image and Woocommerce Featured Product Image. Not working.

    <a href="#" class="browser button button-hero" style="display: inline; position: relative; z-index: 1;" id="__wp-uploader-id-1">Select Files</a>

    Button for Media>Add New>Select Files. Working!!

    <input id="plupload-browse-button" type="button" value="Select Files" class="button" style="position: relative; z-index: 1;">

    Can someone please shed some light on this problem.

Viewing 12 replies - 1 through 12 (of 12 total)
  • supertester


    I’m having the same problem, any updates on this? It seems to be Chrome related, in Firefox it does work.



    I have the same problem. I have two wordpress sites. One the button works on, the new one I just bought doesn’t. Would love to have a solution because it makes it really difficult at times having to hop around so much.

    Thread Starter digimarkup


    The problem seems to come and go. The button start working for me on Monday and stop working again on Friday.This is so weird.



    I have the same problem.
    Some sites have problem with button upload (exclude Menu->Media->Add New).
    Some sites working normal, although all my website use same theme (source from Underscores) and same plugins (Yoast SEO, Akismet, Master Slider)
    All sites working normal on Firefox

    I’m using Chrome Version 56.0.2924.87, WordPress 4.7.3, Window 7



    I am also having this same issue, so far only on one of the many sites we have running wordpress. It was a brand new install that was working just fine and now it does not. I can drag and drop files and that works or I can go to “Add New” in the media menu and use the browser uploader.

    I have tried removing all plugins and using the default wordpress packaged theme and the problem is still persisting. This only seems to be an issue in the chrome desktop browser, chrome on mobile allows me to upload files no problem. Nothing shows in the debug log, server logs or console logs on the pages where its not working. Chrome version: 56.0.2924.87, wordpress 4.7.3, windows 10

    I have cleared the cache in chrome and am going to update and try the latest version to see if it makes any sort of difference.

    The odd thing is that it was working fine and no changes were made to plugins or themes and suddenly it no longer was responsive.

    UPDATE: After updating chrome to the latest version: 57.0.2987.110, and clearing the cache again, the problem is still persisting.

    • This reply was modified 6 years ago by ty_h11.
    • This reply was modified 6 years ago by ty_h11. Reason: update


    Another update.

    There is another thread on the same topic here:

    Worth the read, seems to be an issue in chrome, the suggestion is that it’s something to do with new security implementations in chrome browser.

    Hey guys.. I had the same problem. I changed the browser to Firefox from Chrome and it started working. We need to update the browser it seems.

    As of today, it still is not working in chrome. But only on certain sites!

    Thread Starter digimarkup


    This problem still exists and it only happens in chrome.

    I hope it’s ok to post here, but I wrote about the problem and a temp fix in my blog:

    I unplugged all plug-ins except Yoast SEO and the Yoast is still not working. I am unable to make any adjustments such as enable/disable any buttons. I have the latest WordPress 4.8. My Yoast is also the latest version too. This happens regardless of the browser used. Please Help!

    I have the same problem. I been tried to use different browser, update flash, deleted cache, browser update but doesn’t work. Who can help pls.

    • This reply was modified 5 years, 4 months ago by homewise1.
Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Media upload button is not working.’ is closed to new replies.