Support » Fixing WordPress » Media upload broken on 3.6

  • Hello there!

    My uploads are broken since 3.6 + a server move (switching hosts, I’m now with MediaTemple), it refuses to create a new 2013/08 folder and asks about my permissions.

    As suggested in this other topic, I did the following, but no success…

    – deactivating all plugins
    – switching to the default theme
    – resetting the plugins folder by FTP
    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress
    – and also: chmoding 777, then 775, then back to 755…

    Nothing does. Any clues?

    Many thanks in advance.

    PS. Also tried to make a new install for a fresh new blog and the upload works okay on the same server… So it’s probably not about the host?

Viewing 15 replies - 1 through 15 (of 21 total)
  • Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

    Thread Starter Cleio&Co

    (@exiledesigns)

    Thanks for the help esmi.
    Unfortunately 767 and 766 are also a fail!

    Oh, I notice it says it can’t create uploads/2013/08, but uploads/ already exists. It should be only about 2013/08 isn’t it? Why would it want to create uploads/ again?

    I also note that when I chmod 777 the error message in the media uploader is different. It says that there has been an error, and that I should try later…?

    Thread Starter Cleio&Co

    (@exiledesigns)

    OK, I’ve now tried 777 +
    – deactivating all plugins
    – switching to the default theme
    – resetting the plugins folder by FTP
    Still does not!

    Why would it want to create uploads/ again?

    It doesn’t. It wants to create an uploads/2013/08 folder. Try asking your hosts about potential folder ownership issues.

    Thread Starter Cleio&Co

    (@exiledesigns)

    Unfortunately, host says it’s software related and nothing wrong with it (as my second fresh install proves it).

    Any more clues?

    Note: I also chmoded uploads 777

    Permissions are not a software issue – they are a server issue.

    Thread Starter Cleio&Co

    (@exiledesigns)

    But if setting 777 everywhere doesn’t do, I should assume it’s a problem within WordPress, no?

    No – as this is only affecting your site and not the other 1+ million WordPress 3.6 sites.

    Thread Starter Cleio&Co

    (@exiledesigns)

    I am trying to understand where the issue comes from in order to avoid this pretty interesting ping-pong between WP support and MT support.

    If anybody has additional clues/ideas that can actually help me solve the problem, I thank you in advance.

    The latest I tried was creating a fresh/empty uploads folder on 777 and trying uploading my image, but still: doesn’t want.

    You need to go back to your hosts with this. It’s not a WordPress issue. It’s a setting on the server that is stopping WordPress from creating the 08 folder inside 2013 within uploads.

    Thread Starter Cleio&Co

    (@exiledesigns)

    Back from my hosts: that tell me my permission are alright and everything’s running smooth…

    So what I ultimately did was:
    – re-uploading entirely (including brand new wp-content) a fresh 3.6
    – connect it through my database with the old wp-config.php file
    – making sure wp-content was chmoded 755.
    – trying to upload something… ===> and fail again
    – upgrading wp-content to 777 ===> still fail.

    Thread Starter Cleio&Co

    (@exiledesigns)

    Tried creating the folder 08 manually, then adding the image. ==> Fail, still that error message.

    You cannot create the folder manually. WordPress MUST create the folder itself.

    I am having the same issues also. I installed a fresh 3.6 wordpress, and it installed fine, but no media would upload, always an error. So I used Filezilla to change wp-content permissions to 777, so WP could create it’s own “uploads” folders and sub-folders below it.

    This worked, but now I cannot change my ‘uploads’ folder back to 755, it’s stuck at 777.

    Does wordpress need this wp-content folder to have completely open permissions for the first upload, just to create directories? If I can get that “uploads” folder back to 755, am I going to encounter the same upload error?

    thanks.

    Thread Starter Cleio&Co

    (@exiledesigns)

    Esmi,

    It definitely *is* a WordPress issue.

    With the help of two developer friends of mine (thank you, boys :p) the issue was found, understood and resolved.

    Explanation:
    The problem is related to the 3.5 update
    Before 3.5 you could modify/change your absolute path to media files folders via Settings > Medias.
    Since 3.5 apparently, this has been taken down and is now into the database (which explains why with a fresh DB it worked, and without a fresh DB it didn’t).
    In consequence, if you have moved to a new host, your absolute media folder path most probably changed but WordPress just didn’t consider it.

    How to fix:
    – open wp-config.php
    – add the following line to it:
    define( 'UPLOADS', 'wp-content/'.'uploads' );
    – save and you should be ok.

    More infos:
    http://www.wpbeginner.com/wp-tutorials/how-to-change-the-default-media-upload-location-in-wordpress-3-5/
    http://codex.wordpress.org/Function_Reference/wp_upload_dir
    https://core.trac.wordpress.org/changeset/21852

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Media upload broken on 3.6’ is closed to new replies.