Support » Fixing WordPress » Media upload: An error occurred in the upload. Please try again later.

  • Resolved swisspenelope

    (@swisspenelope)


    Hello

    I cannot upload any pictures whatsoever into posts or pages! I had NextGen gallery installed, but have now deactivated it. The problem persists.

    The upload hangs and then I get the message in the topic title above.

    I use Simple Membership plugin, and don’t want to deactivate that, because without it my site is worthless. I have tried adding
    define(‘CONCATENATE_SCRIPTS’, false );
    in my wp_config file, because someone suggested that 2 years ago in a forum post. Doesn’t work.

    Any ideas?

    P.S. I have cleared all cache, cookies, and so on.

    Thanks
    WP

Viewing 6 replies - 1 through 6 (of 6 total)
  • Pick an off time for your site and temporarily disable the plugins and or try another theme.

    You can’t solve the problem until you know what’s causing the problem, and that involves eliminating any plugin or theme conflicts.

    Ok – I deactivated every single plugin, and still got the hanging, so no chance of uploading to a page.

    I put back Simple Membership as it’s the key plugin, and then decided to try uploading via URL. Have never done that before because never needed to. This works, however!

    Is there any way to reinstall the media library part of WP? I get a related issue when I go directly into the Media library and choose Add New. The dialog says “Cruching…” for ever and ever until I get bored and quit the library, at which point I find the image has uploaded to the library after all.

    And that reminds me, although this may be unrelated, since approx WP 4.0 whenever I update to new versions of any plugin, it hangs while updating, and similarly, when I finally get bored and decide it’s not working, and quit the plugins page, I find that the plugin has updated successfully.

    Does this ring any bells?

    Check with your hosting company. I have one client I inherited that isn’t on my server with all my other clients and I get that same kind of problem from time to time with them.

    I think there may be an issue with the fact that for the time being it is on a dev/test site that is a subdomain of another domain. In August I have to take it live … hopefully that will make the issue go away. (Media insert works on my other WP sites, which are all in their own main domain.)

    Thanks for the suggestions.

    Okay – just to let you know: I diffed my Attitude theme files against the Attitude Child theme I use. (I did this when I found that Attitude allowed media uploads and inserts, but my child theme didn’t …)

    My suspicion was that the offending code would be in the functions.php or in the header-extensions.php, where I had a secondary menu that I concocted. It was in fact the header-extensions.php.

    The simple process of adding back Child theme code chunk by chunk, checking that Insert Media was still functioning, until the site looked and behaved normally, was all it took. So I am not entirely sure what was in the old header-extensions.php that made media insert crash … but it doesn’t any more.

    I also noticed that Attitude doesn’t use certain template files any more, whereas I had them in my Child theme directory, so I moved those to an “unused” folder for good measure, always checking that my site was still working.

    Hope all this helps someone!

    calebsgirl

    (@calebsgirl)

    Hi,

    I have the same exact problem with my blog. I cannot set featured image, when I try to upload it gives me the same error occurred during upload message. I cannot see past images in gallery on the post. The loading button just goes round and round.

    When I go to media Library I cannot view images until I click list then they show. I can only insert images in my posts via URL upload.

    I have deactivated all my plugins – didn’t work.
    change permisions on Cpanel – didn’t work
    Called Godaddy and they were not of much help.
    Called the person who adapted and set up my blog for me and Updated WP and it appeared to work last night but now not working.

    Is there anyone that can help a layman with this problem? There must surely be a solution….Please anyone can explain to me what I can do to fix this frustrating issue?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Media upload: An error occurred in the upload. Please try again later.’ is closed to new replies.