Support » Plugin: WP MediaTagger » Media Tagger not flushing tags when files deleted.

  • I am using Media Tagger with mp3’s. I love it. I am having one problem though. When I delete a file from the Media Library, Media Tagger still shows tags for those deleted files. When I do a search of that tag through Media Tagger I get this:

    Warning: Division by zero in /home/…/wp-content/plugins/wp-mediatagger/mediatagger.php on line 1780

    Warning: Division by zero in /home/…/wp-content/plugins/wp-mediatagger/mediatagger.php on line 1784

    The only thing that clears it is if I delete then reinstall Media Tagger.

    Any ideas how to fix this?

    Thanks

    https://wordpress.org/plugins/wp-mediatagger/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author phd38

    (@phd38)

    Tags are independant from the images or any medias which are tagged. Removing the media does not involve touching the tags, it would be too dangerous.

    Then concerning the div by zero, it should not happen. I would need more data to evaluate the case.

    Thanks for your reply. I think I figured out the problem. I was deleting the files before untagging them in Mediatagger. Thus, Mediatagger was displaying searches as though the files were still there because the tag association was still there (but not connected to a file) – that’s when the warning would show. At this point, if I untag a file and then delete it there is no problem. Thanks again!

    If I delete mediatagger are the tag links also deleted? I deactivated the plugin but the links remain once reactivated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Media Tagger not flushing tags when files deleted.’ is closed to new replies.