Support » Plugin: rtMedia for WordPress, BuddyPress and bbPress » Media Says Uploading But No File Uploads Larger Than 1mb

  • Resolved webgirl


    I’ve been posting on, however couldn’t today because of a database connection error so I came here.

    The problem that I am having is that when uploading audio and video files larger than 1mb the plugin shows that it is uploading on the progress bar but once it finishes uploading, I would just get the message “Sorry, no music were found..” and no file actually uploaded. Actually it was not just audio and video, I decided to test uploading a photo larger than 1mb and the same thing happened. I read the information on the link rtcamp had provided about mime types, however it didn’t apply to me because I’m not using multi-site.

    So, after doing some research, I came across posts that referrer validation and Flash runtime may be possibly conflicting, so I posted again on rtcamp a few days ago about that.

    I decided to search for runtime in buddypress media, and found it in “BPMediaUploadScreen.php,” played with it and did more research. What I found out is that it seems to be a “chunk_size” related problem when using plupload. I decided to put a chunk size line in “BPMediaUploadScreen.php” and I switched around the runtime as “gears,flash,silverlight,html5,browserplus,html4.” I discovered that uploading works fine on larger files with the chunk size line included and the runtime switched some, but then it is only when using the Upload tab. After those changes, I still couldn’t upload more than 1mb from the photo and music tab, only from the Upload tab itself.

    Another problem that occurred after making changes to the “BPMediaUploadScreen.php” is that once it finished uploading the file, the file was duplicating four times. It showed four times on the site and four files in the upload folder.

    Please understand I do not wish or am I planning to keep the changes I made to “BPMediaUploadScreen.php,” but I was just trying to obtain as much information to provide you as I could to help solve the problem of media files not uploading more than 1mb.

    This is where I am so far. I would love to get this solved as I am very interested in using Buddypress Media and purchasing some of the add-ons, but I would like to get this problem solved of not being able to upload more than 1mb because surely I can’t activate audio and video until users are able to upload more than 1mb.

    Also keep in mind before resorting to looking in “BPMediaUploadScreen.php” I already tried the following:

    1) I checked my php.ini settings and can verify that they are beyond what is required to upload for this plugin. I previously had it set on 1024M.
    2) I have tried uploading using different themes and still get the same results. No file uploaded and the message saying “Sorry, no music were found.”
    3) I can upload larger than 1mb fine from the wordpress admin dashboard under the media library as well as when uploading posts to the site.
    4) Turned all plugins off except for Buddypress and Buddypress Media and still the same issue.
    5) I also tested this on a separate domain with a fresh install and the same problem. No mp3 file or video files upload larger than 1mb.

Viewing 8 replies - 1 through 8 (of 8 total)
  • mmm… You actually did everything and problem remained! I had such a problem before, also double check these issues:

    1- limited max file size in header.php or wp-config.php
    2- check the post file size in php.ini
    3- restart your server (if u have access)

    Finally consider that the 1024M is a really huge size for max file size upload or post upload :O it might be 1024K which means exactly 1 megabyte!

    Hi John, Thanks for chiming in, actually I’m sure it was 1024M here is a previous screenshot No, there are no file size settings set in the header.php or wp-config.php.

    The post_max_size and upload_max_filesize are both the same size and were actually changed from 1024M to 300M. I’m very familiar with the K and the M for kilobyte and megabyte. Actually I already tried a restart of the server but again there was no change. Thanks again for chiming in.

    By the way, you said you “had” a problem. Did you work out the problem?

    As I stated previously, it is seemingly associated with plupload and the chunk size.

    Plugin Contributor Joshua Abenazer



    Thanks for such a detailed description of the problem.

    We have already been exploring this, but were making other major changes to BuddyPress Media and kept this on a back burner. However, we are now done with the next set of changes and will include chunk size support to allow uploading large files.

    This will be out in the next release with some other improvements, due in the next few days.

    @webgirl Sorry for late, I put the below code in .htaccess:

    php_value upload_max_filesize 256M
    php_value post_max_size 256M
    php_value max_execution_time 300
    php_value max_input_time 300

    Hi John, that’s ok. We are all busy bees. I already had everything in my php.ini except max_input_time. Nothing seemed to work other than adding chunk_size which Joshua said should be added in the next release with some improvements which I am surely awaiting. 🙂

    Thanks again.

    I see there have been about 4 updates since I reported an issue with not being able to upload files larger than 1mb. Do you have a time estimate of when chunk_size support will be implemented?

    I would think this would be a high priority on the list since this is what the plug-in was meant for — to allow the uploading of photos, audio and video. Being limited to 1mb leaves no option but to leave the uploading of audio and video deactivated. The reason I say this is because it is very common for audio and video files to be larger than 1mb and it is a very slim chance that a user would upload an audio or video file less than 1mb. An average .mp3 audio file is 3.5mb and an average 5 minute mp4 video file ranges from 20mb – 100mb depending on pixel size and converter. The same pretty much goes for uploading high quality photos because it can reach well over 1mb as well.

    Again, do you have a time estimated, I know you said it will be out in the “next release with some other improvements,” just trying to see how long before this is resolved as I know others including myself are waiting for this to be fixed?

    Plugin Contributor Joshua Abenazer


    @webgirl – Sorry for not following up with you.
    For the seamless integration of chunk size we would have to refactor the uploader code and make it more flexible. We have uploader refactoring on our roadmap which is expected to release around the end of this month. The chunk size should be implemented once the uploader refactoring is done.

    You can checkout the roadmap here to get an idea of the upcoming releases.

    Thank you greatly Joshua for the update and updating the roadmap. 🙂

    I’ll be on the lookout.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Media Says Uploading But No File Uploads Larger Than 1mb’ is closed to new replies.