WordPress.org

Support

Support » How-To and Troubleshooting » Media (pdf) uploads not working

Media (pdf) uploads not working

  • My client has multiple domains running through the same WordPress site. Suddenly they are no longer able to upload PDFs to their posts or their media library. They do not get an error that WP is unable to create a directory (as many other posts on the same subject have gotten), but they get ‘the uploaded file could not be moved to (filepath)’. My workaround is to have them FTP the files to the desired location, then hand-code the link to that file. Obviously, this will not work for long.
    I’ve set the permissions for those folders at 777 as well as the blogs.dir folder as I had seen suggested on another post dealing with the same issue.

Viewing 12 replies - 1 through 12 (of 12 total)
  • I think that is still the same permissions error. What folders did you set the permissions to 777 on? Also, please don’t do that. 777 is dangerous and hopefully isn’t necessary.

    OK. On other posts they suggested 777. What should I set it to?

    I know. There are a number of place that suggest 777, but its a bad idea. Anyone can write to the directory. Leave it at 777 until you get the file problem solved then we will back down the permissions to something safer. What directory are you talking about? WordPress will use /wp-content/uploads plus subfolders by default. Is that what you have?

    You didn’t say whether or not they also started not being able to upload other file types, so I’m figuring they did?

    There is a “Upload file types” setting in Network Settings that allows for certain file types if it became corrupted or doesn’t have PDF in there for some other reason, it won’t allow the uploads. I can’t see how to edit this on a site by site basis straight away. PDF if the last one on my line.

    Also, there’s a max file upload size set there.

    I’m referring to the Network Version of WordPress because you stated the client had multiple domains.

    Oh, and fwiw, can you get the owner and group for the wp-content directory?

    Oh, and fwiw, can you get the owner and group for the wp-content directory?

    Now you are spoiling the surprise 🙂 That shouldn’t matter with permissions at 777 but sorting out the owner and group is how I intended to back those permissions down.

    I think the file size issue would show up on upload, not when the file was being moved, but definitely worth looking into.

    Did you see my first reply?

    rtcg: PDF is in that list of allowed docs. Also, file size is set at 10mb and these pdfs are less than 1.

    Any other possibilities?

    also, apljdi, the error said the word ‘move’, but they told me they got it when they were trying to upload the file. They can’t upload (or move, I guess).

    http://cl.ly/153B0q0I081D06122o0N

    This is a screenshot of the error message I receive when I try to upload media.

    Did you see my first reply?

    Yes, but I don’t know what you are talking about.

    That looks like the same very common permission related upload error that you’ve read about. I’m pretty sure that somewhere you’ve got the permissions wrong. So, starting at wp-content, what are the permissions on each directory in that path? Also include the user and group for each, please.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Media (pdf) uploads not working’ is closed to new replies.