Support » Plugin: Enable Media Replace » Media not replaced, but no errors

  • I’ve used your plug in the past and been very happy with it. I’m working on a new site and installed the plugin to replace an image. Looked like everything worked fine, but the old image is still there. I tried again incase I didn’t do it correctly with the same results. I checked in another browser in case it was a cashing issue, but it’s showing the old image as well.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author ShortPixel

    (@shortpixel)

    Hi,
    thanks for your message, sorry to hear about this issue.

    Could you also please check the permissions for the file that needs to be replaced to make sure that’s not causing the issue?
    If that was the case please do let us know.

    If that was not the case please do let us know as well here so we can investigate this further with you.

    Thanks,
    Alex

    It could still be caching.

    This happens to me with the server-side caching from my hosting company – it really helps with the site performance, but replacing a media file doesn’t work (my hoster is Siteground). I have to deactivate the server-side caches, flush them, replace the image, and then turn the caching back on. It’s faster to just upload a new image file with a new filename.

    A similar issue arises when you’re using Jetpack with Photon and/or Tiled Galleries (the latter always use Photon to render the thumbnails on the fly). The Photon CDN has absolutely no way to determine whether the file has been updated if it’s using the same name. As far as I know, the Photon CDN cache has no expiration – images are cached there forever, and the only way to flush the cache is by contacting Jetpack support.

    It’s probably the caching issue–I’m also on SiteGround. I’d just manually replaced the file. Guess I’ll just have to continue to do that. Thanks for the info.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Media not replaced, but no errors’ is closed to new replies.