Support » Fixing WordPress » Media Library won’t load & can’t update plugins or themes

  • Hi

    I’m having a problem with my WordPress site.

    The site won’t let me update plugins or themes, I get this message:

    Update Failed: Connection lost or the server is busy. Please try again later.

    I also can’t view the media library, I just get the spinning loading icon.

    I’ve tried everything I can think of to find out what the problem is, I’ve:

    – Updated WP to latest version (4.7.3)
    – Disabled all plugins
    – Disabled my theme and activated the WP Twenty Sixteen theme
    – Re-installed WordPress via dashboard > update
    – Replaced the core files of WordPress using FTP
    – Tried a different browser

    I’ve contacted my webhost to ask if they can see if everything was alright their end but they weren’t very helpful, they just set up a custom php.ini file with increased values.

    The site has been working fine prior to this, has anyone any ideas what the problem could be?

    Thanks

    • This topic was modified 3 years, 6 months ago by markthedoc.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Had an issue with one of my plugins this morning, the developer had been pulling his hair out, but it turned out it wasn’t his fault, the Plugin’s new version that he uploaded was not updating users’ plugin and when we looked at the details, it displayed an even older version… had to resort to giving us a link to a different repository whence we could download the zip file and upload it from outside the WP site.

    I suspect something major – Update? hack? power failure? – may have struck our valiant WPeers. I hope things sort themselves out, for their sake and ours! 🙂

    @markthedoc have you enable the WordPress Debugger to check if something pop up in there? https://codex.wordpress.org/Debugging_in_WordPress

    Other potential cause can be server timeout issue, have you check that?

    @geavox would be better if you can open a new thread for your issue

    • This reply was modified 3 years, 6 months ago by jascore7.

    Cheers @jascore7 I’ll try that.

    Just to let everyone know the outcome – I decided to move the site to another server of mine and the site works fine on that. No idea!

    I am having the same problems, using theme twenty seventeen, did all but replace the core files, since I am not sure how to do that, will try the debugger link. And, also would not know how to move to new server, not sure if I have another one.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Media Library won’t load & can’t update plugins or themes’ is closed to new replies.