Support » Fixing WordPress » Media Library Uploads Not Working

  • Resolved HopefulGJL

    (@hopefulgjl)


    Hello!

    I have been trying to upload media to my media library without success. I keep receiving error messages about whether or not the directory and/or parent directory on the server is writable or not.

    This is happening whether I try to upload .jpg, .doc, or .docx and whether I use the flash or browser uploader. It is also happening with Firefox or with IE (and both the browsers are up to date).

    I have called my hosting company (Hostgator) and have been assured that both that directory and its parent directory are writable.

    I’m a true beginner at all this so I request plain English details and I really appreciate your time in answering this question. Thanks in advance!

Viewing 2 replies - 1 through 2 (of 2 total)
  • I had someone I know help me resolve this.

    1) In my WordPress control panel -> Settings -> Media; Uploading Files section, Store uploads in this folder field:
    The file path was /wp-content/uploads and needed to be changed to wp-content/uploads (so the first slash before the wp-content needed to be removed)

    2) I was using the Backup WordPress plugin. That plugin, for an unknown reason, was storing the back-up files in my media upload folder in my C-Panel. Those backup files contained a file that had a deny access control on it.
    What he did was create a new back-ups folder in my C-Panel and then moved all of the back-up files from the media upload folder to the new back-ups folder.

    Once these tasks were complete, my media uploads started working.

    I hope this helps anyone who might run into the same issue.

    Thanks for reporting back the ressolution! You should use the dropdown to mark this thread resolved. That way in the future, people will know that this thread contains a potential solution

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Media Library Uploads Not Working’ is closed to new replies.