Support » Networking WordPress » Media Library subdomain issue

  • Resolved kallenavn

    (@kallenavn)


    I did install WP-multisite today and everything works as it should, except the media library to the sub domains. The pictures I upload won’t show.

    I have the “blogs.dir” in wp-content. What have I done wrong?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Are the pictures actually being uploaded in that folder to the right subfolders?

    Can you see them in the media library or is it just the theme on the front end?

    Thanks for your reply.

    How it looks in the media library:
    http://i472.photobucket.com/albums/rr89/sondreroe/c9cf6211.png

    Here are the pictures in the blogs.dir folder:

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    What’s in your .htaccess?

    My .htaccess:

    # Use PHP5 Single php.ini as default
    AddHandler application/x-httpd-php5s .php
    
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file= [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress
    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Well that’s fine. Darn.

    You didn’t move this install, did you?

    No. Installed everything today.

    Argh!

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Right click on the images from media library. What URL are they showing?

    http://test.another.no/files/2012/01/testpic-150×150.jpg

    It’s something wrong with the position?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    No, that’s correct. But it makes me think your server’s not handling the added rules in your htaccess correctly. Check your httpd.conf file and make sure allowoverride is set to all.

    Never heard of httpd.conf? Maybe that’s the problem? Where should I add it (public_html right?), and what should be in the file?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    It’s a server file, not something for your account, but the entire server.

    Have you root access to your server? If not, ask your webhost.

    I asked my webhoust about httpd.conf:

    AllowOverride Options=ExecCGI,Includes,IncludesNOEXEC,MultiViews,SymLinksIfOwnerMatch,Indexes,-FollowSymLinks are enabled.

    these settings are not changeable. however they are also sufficient for multisite to work on our servers, as we have customers who use it successfully.

    It’s obviously something I’ve done wrong? Should I reinstall?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Does it fail on ALL sub blogs or just some?

    It fails on all sub blogs.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    AllowOverride Options=ExecCGI,Includes,IncludesNOEXEC,MultiViews,SymLinksIfOwnerMatch,Indexes,-FollowSymLinks are enabled.

    these settings are not changeable. however they are also sufficient for multisite to work on our servers, as we have customers who use it successfully.

    Then go back to them and describe the issue in this thread. Nothing we can do on our end.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Media Library subdomain issue’ is closed to new replies.