Support » Fixing WordPress » Media Library not working when uploading in WordPress 2.8.4

  • Resolved comcorp


    Hi All–

    We operate and have installed many versions of WordPress and we have currently installed 3 fresh installs of WordPress 2.8.4. On all 3 installs we are having problems with the Media Library. The media library in not uploading the media file (images in this case) to the server nor resizing them.

    We have created the “uploads” folder on the server as well as changed the permissions to fully writable 777.

    Is there something that we are missing?
    Is there a problem with the version of WordPress and the media libaray?

    Thanks in advance.

Viewing 15 replies - 1 through 15 (of 16 total)
  • esmi


    Forum Moderator

    Is there a problem with the version of WordPress and the media libaray?

    There’s no known bug that I know of. Are all 3 installs on the same server? Are any of your other installs on the same server?

    Yes, the fresh installs are on the same server and the others are on the same server as well.

    Maybe it is with the file permissions?

    We’ve created the directly “uploads” and permissions are 777. Are there any other steps that we are overlooking?



    Forum Moderator

    You could try chmod’ing the wp-content folder to 777 initially then, if it works, switching it back to 755 afterwards. Are you getting any error messages?

    wp-content folder was at 777

    hmmm…Let me try something on the server.

    Well I changed some server configurations and it wasn’t that.

    I uploaded an image to the media library and it show up in the library with no image.

    It even designates a URL:

    However the images is not there.

    Okay, I upload Barbara_Abello.jpg using the media library and it uploaded the file and created thumbnails in the wp-content folder, but not the “uploads” folder.

    Any suggestions now?

    Same issue here. I thought i Was messing it up. I am new to WordPress but I have done all of the changes ans noted above and 4 fresh installs with still the same issue.

    Any other suggestions?

    I am using WordPress 2.8.4 hosted on
    The site test address is

    I hope there are some additional ideas.


    I’ve found the problem.

    In Settings –> Miscellaneous

    Make sure that you have wp-content/uploads typed in the “Store uploads in this folder” field.

    It says it has “wp-content/uploads” by default, but this is not the case.

    I just downgraded to WordPress 2.7.1. and its working fine now…. was anyone able to repeat the issues?

    Hi, I am facing the same issues.
    When I upload files it is not getting uploaded. I manually created the uploads folder (777 permission) and put the files through ftp(after creating year and month folder with 777 permissions). However I am not able to view the files in Media Library.

    My Settings:
    “Store uploads in this folder” is wp-content/uploads.
    “Organize my uploads into month- and year-based folders” is ticked (I tried to do without ticking this option and also loading the images in base uploads folder).

    Would appreciate if someone can help me with this problem.


    i had troubles adding images when writing new post, so i looked here:
    line 43:

    if ( intval($_REQUEST['post_id']) )
    if ($_REQUEST['post_id']<0){$_REQUEST['post_id']=0;} //fix
    //if you comment out previous line, post id will be negative
    echo "<p style='font-size:25px;text-align:right;'>post-id:".$_REQUEST['post_id']."</p>";

    seems working now

    Comcorps post about “Settings –> Miscellaneous –> Store uploads in this folder…” was the answer for me!

    I think the trouble started when I wanted to change directories. I tried moving it using the General tab to change the url but that did not work. I then had one our IT gurus physically move the files but I now realize that one must use the wordpress mechanism to move things because in doing that, I assume they write or generate the right addresses or links inside the files which did CANNOT happen when my IT guy dragged the files over.

    In any case, thanks Comcorp!



    Thanks for your comments, but still not able to upload.
    My queries are (a little more info since my last post):

    Part 1:
    If I try to upload an image in a post directly from my computer then wordpress shows me the error “File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini.
    However I am able to upload the files through ftp. So am I really not able to upload due to php.ini or is there some other reason??
    Part 2:
    Also, when I try to upload through Media->Add New , it does not show any such error – but it does not upload the file either.
    Part 3:
    And also repeating part of my original query: Even I ftp upload the image, wordpress Media Library does not recognize those files.


    Thanks comcorp – your fix worked for me too – thought I was going mad for a minute there!

    I’ve found the problem.

    In Settings –> Miscellaneous

    Make sure that you have wp-content/uploads typed in the “Store uploads in this folder” field.

    It says it has “wp-content/uploads” by default, but this is not the case.

    I’m also having a problem with this, and am pretty familiar with WordPress, having installed many versions on many different sites in the past.

    -I’m using WP 2.4.8,
    -My wp-content folder has permissions set to 777,
    -My uploads folder is set to ‘wp-content/uploads’ in the Miscellaneous settings section,
    -‘Organize my uploads into month – and year- based folders’ is checked.

    Normally when I upload an image, it says ‘crunching’ for a moment, then the image thumbnail is displayed, with all the alignment/title/caption/insert into post options.

    In this case, it just shows the image filename, no thumbnail, and a ‘show’ link that doesn’t work.
    In the ‘Gallery’ or ‘Media Library’ tabs at the top, it’s the same thing: no tiny thumbnail on the left, and a ‘show’ link that doesn’t work.

    However, coming out of there completely and looking in the ‘media’ tab on the main WordPress leftnav, there’s my image. I can click on it and see a medium sized version, click on that and get the full sized one.

    Going back to my page to try and insert that image from the page gallery or the media library still doesn’t work.

    Here’s a possible clue though:
    I have only uploaded an image into this install of WP today (Oct 1st) for the first time.

    Looking via ftp into wpcontent/uploads/2009/
    there are 2 folders: /09 and /10

    The /09 folder contains my uploaded image (plus the scaled versions of 150×150 and 300×102 that wordpress creates when uploading).
    The /10 folder contains nothing.

    I checked my timezone settings and they are set to UTC+1 (Correct for London UK, no?)

    Not sure what else to check..
    Can anyone offer any further suggestions?

    Thanks in advance

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Media Library not working when uploading in WordPress 2.8.4’ is closed to new replies.