WordPress.org

Forums

[resolved] [closed] Media Library not working properly after 3.8.1 update (12 posts)

  1. Annawari
    Member
    Posted 1 year ago #

    I can upload images to the media library without any problems. But when I try to insert images or a gallery into a post/project/page the images I recently uploaded to my library don't show up.

    I can upload them again while creating a gallery for a post for example, and everything shows up some what OK (square images are being stretched out) on my website but when I want to edit/or add to the gallery all the pictures are gone.

    I checked where my images are being uploaded and they're where all my other pictures are (public_html/wp-content/uploads/2014/01).
    I'm not entirely sure the 3.8.1 update is the source of my problem because I also tried a few new gallery plugins right around the time of the update. (WP Photo Album Plus and Photospace Gallery & I was already using NextGen)

    I deleted all gallery plugins and just kept the plugins that were working fine before the 3.8.1 update.

    Does anyone have an idea what's going on ?

  2. Annawari
    Member
    Posted 1 year ago #

    I figured out it was the WPML Multilingual CMS Plugin that was causing the problem. (disabled all plugins and reactivated them one by one).

    Then I found the solution on a WPML forum:

    1. Go to your Media Library and locate an image file. Click on "Edit" to go to the "Edit Media" screen of this file.

    2. Scroll all the way to the bottom of the page and look for the "Make 'Media' translatable" checkbox.

    3. It should be disabled. If it is already disabled, enable it first the save. Next disable it and save again. This will cause WPML to re-save its settings.

    4. Visit the "WPML settings" ("WPML -> Support -> Troubleshooting") again and search for [custom_posts_sync_option] you'll see that [attachment] is on 0 as it should be*.

    * It should be either on 0 or not there at all!

  3. sona2014
    Member
    Posted 1 year ago #

    I have the same problem. I tried inactivating all plugins but it didn't make any difference.

    I cannot even click on text icon.

  4. gleenk
    Member
    Posted 1 year ago #

    Wow thank you so much Annawari! I got the same problem with WPML and solved it!

  5. Cablewaves
    Member
    Posted 11 months ago #

    Thank you very much! Lifesaver.

  6. mrfoxtalbot
    Member
    Posted 8 months ago #

    Worked! Thanks a lot for figuring this out!

    I was using the latest version of WP (4.0) and WPML (3.1.7.2) and I must say it´s not very impressive that 7 months later the folks at WPML still haven´t fixed it yet.

  7. stefbonnet7
    Member
    Posted 8 months ago #

    Thank you, thank you, thank you. I searched left and right for the solution yesterday and the WPML forum was not that helpful at all. Can't believe they couldn't give that simple tip.

    I now have to clean up the thousands of ghost thumbnails that it created but at least I can work with the posts with your fix.

    It's the second time that WPML messes up with a WordPress release. Not impressed !

  8. mhdesigns
    Member
    Posted 6 months ago #

    Hello Everyone,

    I've been trying to find a post that might be a little closer to what my issue might be, this post seems to be the closest with some exceptions.

    1. I am using a Child theme for the CATCH KATHMANDU theme on WP version 4.0

    2. The issue with the media library not loading seems to only happen when I am running the Child Theme.

    3. I've tried deactivating all the plugins - but that didn't help.

    4. I've tried re-installing WP

    5. I can activate the parent or any other theme and the problem goes away.

    6. I can upload/insert images into pages or posts but I can't access any of the images in the library.

    7. I've unchecked "Organize my uploads into month- and year-based folders" in the Media Settings.

    I was thinking that maybe there is something I should be doing in the Child Theme functions.php file..

    Here is what I have at this point.

    <?php
    /**
     * Catch Kathmandu Child functions and definitions
     */
    
    /**
     * Enqueue scripts and styles
     */
    
    add_action( 'wp_enqueue_scripts', 'enqueue_child_theme_styles', PHP_INT_MAX);
    function enqueue_child_theme_styles() {
        wp_enqueue_style( 'parent-style', get_template_directory_uri().'/style.css' );
        wp_enqueue_style( 'child-style', get_stylesheet_uri(), array('parent-style')  );
    }
    ?>
    
    <?php
    function catchkathmandu_child_scripts() {
    
        wp_dequeue_style( 'catchkathmandu-responsive', get_template_directory_uri() . '/css/responsive.css' );
    	wp_enqueue_style( 'catchkathmandu-custom', get_stylesheet_directory_uri() . '/style.css' );
    
    }
    add_action( 'wp_enqueue_scripts', 'catchkathmandu_child_scripts', 20 );
    ?>

    The front end of the site and everything else seems to be working just fine.

    Please Help :) thanks.

  9. tonyle
    Member
    Posted 6 months ago #

    Hello,
    My media library not loading with WP 4.01, WPML plugin,... : http://i.imgur.com/EwjjrK7.png ,
    Anybody show me how to fix it
    Thanks

  10. Cristi Roberts
    Member
    Posted 5 months ago #

    I don't have WPML plugin and my media library is doing this. I deactivate my plugins and reactivated them and that didn't fix it. Any ideas?

  11. WPyogi
    Forum Moderator
    Posted 5 months ago #

    @Cristi Roberts - could you please start a new thread so someone can help you better?

    Thanks.

    here's the form:

    https://wordpress.org/support/forum/how-to-and-troubleshooting#postform

  12. mhdesigns
    Member
    Posted 5 months ago #

    I've resolved my issues by not using a child theme with the parent CATCH KATHMANDU theme. I ended up using the CSS section with in the theme and this has worked fine.

Topic Closed

This topic has been closed to new replies.

About this Topic