WordPress.org

Support

Support » How-To and Troubleshooting » Media Library Not Showing Images

Media Library Not Showing Images

  • Hi

    I’ve just switched my website from localhost to server and it all seemed to go smoothly (or so i thought)
    For some reason now i can’t upload any images using the WP uploader. Its not showing any thumbnails for the shots in Media or anything. I’ve tried adding the images via FTP and linking to them on the pages and that seems to work but they wont show in media library.

    Have tried the obvious things like clearing the cache, fresh install of wp files etc but nothing seems to help. Running out of ideas now.

    Any suggestions?

    Cheers
    MJG

Viewing 15 replies - 1 through 15 (of 22 total)
  • I’m having the exact same problem. It all worked (and still does) fine on my localhost, but WordPress on a remote server will upload/crunch … but then no thumbnail appears in the Media Library. Attached to a post doesn’t work either … but strangely, when I choose to edit the item, it appears … but only when I click edit. FTP shows me the image, so it does upload. There just seems to be something broke in the upload process.

    Did you solve this problem?

    Hi,

    Same here, i can upload my images, but they do not show up in the library except for a little question mark ?
    When I try to edit them, I can see them, but only in editing mode.

    Can some one help pleeeeeeeease

    Thanks

    Reto

    I actually sorted this problem for myself. It maybe not solve yours, but it was a permissions problem with the folders I copied over to the remote server. The permissions need to be set to 755 … so I changed the folder permissions to 755, and it solved my problem. Good luck!

    hi,

    what are the names of these folders ? and the path to find them ?

    thanks a lot for your help

    Reto

    how to change folder permission???

    The path to the uploaded files folders is:

    wp-content/uploads/

    … if you are using Dreamweaver (or another FTP application) … you should be able to set/change the permissions by getting the properties of each folder.

    You’ll need to set the permissions for each folder (including the uploads folder) that you added/FTP’d to the remote site. Any folders created by WordPress will automatically set the permissions to 755.

    wp-content/uploads folder as well as the folders within are changed to 755.

    it is not working.

    I have bought a “zeus” theme (you can see it on http://www.soundfountain.co.uk)

    The instructions I got from them is to set the permissions for the following folders to

    777 and if that doesn’t work I should try ( 775 or 755 )

    theme-folder/framework/cache
    theme-folder/framework/temp

    I have tried all options but nothing works ?
    I am lost 🙁

    Hi Guys did anyone solve their problem here?

    Mungobee what the problem u have

    Hi Meky
    thanks for responding.
    My problem is that I cant see the images in media library. at least until I attempt to edit the image.
    I try to upload them/insert them and I get the outline of a box but no image.
    There is no thumbnail displayed except the outline of a box and a very little icon in the middle of the box.
    I have spent hours going around in circles trying to understand this problem some things that I have checked and discovered.
    I have removed all plugins
    I am attempting to resolve it with the basic theme 20 10.
    I have checked to see that the image is loaded in filemanager of cpanel. It is however what I have also seen and dont know if it is right is that I have mutiple folders with jpg content
    I have files in cpanel file manager at this address
    public_html/wordpress/wp-content/uploads/2012/06
    and this address
    www/wordpress/wp-content/uploads/2012/06

    when a jpg file is uploaded it arrives in one of the folders as five different files. The original plus four other files each smller than the main one.

    So I am imaging there is something wrong with the filemanager in Cpanel.

    Being a newbie at wordpress cpanel I am unsure if any of this is behaving the way it should and am considering reinstalling the entirety of wordpress and beginning again.
    Not sure if that is confusing or helpfull
    thanks Meky_P

    I had the same problem a while back. It was down to the permissions set by WordPress. I can guess that you probably copied the “uploads” directory to your server? In that case, the permissions are fine on the folders copied up, but new folder permissions are not set correctly by WordPress. You may have to set these permissions to 755 manually … as I did.

    Hi Isometricshadow,
    Thanks for the interest.
    I changed the permissions to 755 but that didnt change it.
    When I look inside the folder of the file manager in cpanel i can see that the file has been saved into 5 different files.
    Each file has a different pixel sizeing
    Is that was is supposed to happen?
    There is the major file (which is the one I try to insert into a page but there is another four files there which are smaller.

    WordPress creates these other images for thumbnail purposes. So, don;t worry about that … it’s normal. In relation to your permissions problem, the issue resides with the read permissions. You obviously have write permissions, as the file does upload.

    Try checking the permissions on all sub-folders too. So, for example, uploads > 2012 > 05 … each of these folders must have their permissions set to 755.

    Worst case scenario, delete the folders manually. Then recreate them with the correct permissions manually. It’s a pain in the ass … believe me, I know … but it does work.

    Hi isometricshadow
    Yes the file is uploading.
    I can see it in Media Library when I choose edit
    However it is not there prior to that in thumbnail form.
    I have altered all of the folders permissions all the way back up to and including wp-content to 755.
    Still no change.

    Is it possible that there may be something wrong with the way that wordpress was installed?

    First of all, did you copy (FTP) the folders from your local version of WordPress to your online (server) version of WordPress?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Media Library Not Showing Images’ is closed to new replies.
Skip to toolbar