Support » Plugin: Xmas Decoration » Media library failed to load.

  • Hello!

    Recently, I have found that your plugin make media library failed to load. After pressing button “add media” in post/page add screen, or after choosing media category in admin dashboard – only blank page showing with eternal loading.
    After manually turning on & off all my plugins, I have found that exactly your plugin is a problem. Very sad.

    Can you fix it? Thank you and good luck!

    https://wordpress.org/plugins/xmas-decoration/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author meohen1989

    (@meohen1989)

    xmas-decoration plugin just do sth with your header, nothing with your admin site.

    Try delete and install xmas-decoration again.

    Thanks for report.

    1

    (@f4tal1st)

    Hello!
    Yes, I understand idea of this plugin, and how it work (should work). Deleting and restoring plugin back and fourth just do not work. The only thing that can be is theme incompatibility. I am using socialviral theme and changing it back to default one (2015 theme/2016 theme) makes this plugin works like a clock. Strange thing…
    Thanks for helping! =)

    Plugin Author meohen1989

    (@meohen1989)

    my website works fine with social viral theme, you can check here 🙂

    http://meohen1989.esy.es/

    Hi, f4tal1st!

    Try to change the last two lines in the plugin file xmas-decoration.php:

    add_action('wp_footer','xmas_decoration');
    add_action('wp_footer','xmas_decoration_load_script_style');

    to:

    if ( !is_admin() ) {
    add_action('wp_footer','xmas_decoration');
    add_action('wp_footer','xmas_decoration_load_script_style');
    }

    This will disable the plugin in admin dashboard.

    1

    (@f4tal1st)

    Hello here.
    Strange thing is, – I deleted this plugin two days ago and download it few minutes back again to test your, kammak, solution.
    And strange and obscure, – now this plugin works but itself, without any hacks and redacting.
    Ohh… That’s a very odd thing…
    Thanks everyone, I guess problem solved by itself.

    He no sound?

    Yeah… This plugin has no sound, but original source js code (Holiday Garland With Ringing Balls) – has.
    I found the original source code and rewrote this plugin,
    on my website now it have a sound.

    Коллега, а не поделитесь Вашей наработкой? Или хотя бы исходниками с того сайта и намеком где что поправить? В коде на Вашем сайте заметно изменение имен функций, но не более. Вопрос – как подключить файл звука .swf 🙂 ? Спасибо.

    In kvazi-english: Colleague, and do not share Your time? Or at least source from the site and hinting where to improve? In the code on Your website noticeable change function names, but no more. Question – how to connect your sound file is .swf 🙂 ? Thanks.

    Легко: xmas-decoration.1.5.zip
    Плагин устанавливается стандартным способом. С наступающим!

    Спасибо огромное. Я уж честно не рассчитывал 🙂 и вчера накодил сам. Колокольчики зазвенели, а снег – отключился!
    Какая то проблема с одновременным подключением 2-х Jquery.js. Подключаешь попеременно – то одно работает, то другое.
    Сравниваю с Вашим сайтом. Но у Вас обе подключаются и пашут.
    Может есть правило их подключения в данном случае – каждую для своего плагина? Я в js пока слаб.
    Также желаю прекрасного новогоднего настроения. С наступающими!

    Thank you very much. I honestly did not expect 🙂 and yesterday nakodil himself. The bells rang, and the snow is down.
    What is the problem with simultaneous connection of 2 x Jquery.js. Alternately connect one or the other works, then more.
    Compare with Your site. But You both are connected and working.
    Maybe there is a rule connecting them in this case – for each of your plugin? I in js is weak

    Да нет, зачем же два раза подключать одну и ту же библиотеку jquery, вполне достаточно это сделать один раз. Там, насколько я помню, кроме библиотеки jquery надо подключить пару ява-скриптов и обязательно подключить ринг-тоны (swf), которые собственно и есть звук…
    В этом плагине в версии 1.1 от Tran Meo, как раз и не было ринг-тонов, поэтому и не было звука.
    И в ява-скриптах надо было прописать имя файла ринг-тонов, м.б. поэтому я где-то что-то и изменил в именах функций, не помню…

    Ну понял, спасибо. Вроде я так все и сделал. Но снег отключается 🙂
    Буду ковырять дальше.
    Еще раз с наступающим!

    Снег – ведь это другой плагин? Значит имеет быть место конфликт плагинов. Попробуйте для снега какой-нибудь ещё. Я, например, использую вместе с Xmas Decoration плагин WP Super Snow. Они одновременно работают и друг другу не мешают. Кроме того WP Super Snow имеет в своих настройках возможность запретить его работу на мобильных устройствах, так как снег это очень крутая анимация и может в момент посадить аккумулятор мобильника…

    Коллега, спасибо, но именно Xmas Decoration и WP Super Snow у меня и стоят 🙂 Почему то включаются только по отдельности. WP у меня последний перед 4.7 – на 4ю7 пока не обновлялся – надо изучить апгрейды.
    Все таки как то неправильно видимо у меня jqury подключаются – на Xmas Decoration jQuery v1.7.1 а вообще на сайте – jQuery v1.12.4 – то же самое у товарища kammak.
    Но у него же работает блин:( !

    Хех, работает старая добрая хакерская система – еще с 90-х помню – не получается – махни 250 гр. и все получится! 🙂
    Приехал с гостей, уложил детей – залез на эту проблему и вауля ! 🙂
    Оказалось цеплять надо функции не к ‘wp_footer’ а к ‘wp_print_scripts’,
    Все таки у kammak было вернее. Снег идет! Бубенцы звенят! С наступающим, коллеги!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Media library failed to load.’ is closed to new replies.